summaryrefslogtreecommitdiff
path: root/dev-libs/libfmt/libfmt-3.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/libfmt/libfmt-3.0.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/libfmt/libfmt-3.0.1.ebuild')
-rw-r--r--dev-libs/libfmt/libfmt-3.0.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/libfmt/libfmt-3.0.1.ebuild b/dev-libs/libfmt/libfmt-3.0.1.ebuild
new file mode 100644
index 000000000000..577be5b9940a
--- /dev/null
+++ b/dev-libs/libfmt/libfmt-3.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Small, safe and fast formatting library"
+HOMEPAGE="https://github.com/fmtlib/fmt"
+
+LICENSE="BSD-2"
+IUSE="test"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/fmtlib/fmt.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/fmtlib/fmt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/fmt-${PV}"
+fi
+
+DEPEND=""
+RDEPEND=""
+
+src_configure() {
+ local mycmakeargs=(
+ -DFMT_TEST=$(usex test)
+ -DBUILD_SHARED_LIBS=ON
+ )
+ cmake-utils_src_configure
+}