summaryrefslogtreecommitdiff
path: root/dev-libs/libfilezilla/libfilezilla-0.18.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-25 19:33:39 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-28 08:31:11 +0100
commitad6182343997a405079870a2fe91c4e0c6b94595 (patch)
tree4aa7483cd0ad7de54338afc8e7971417abe1dd81 /dev-libs/libfilezilla/libfilezilla-0.18.2.ebuild
parente8f81810baa21f490d6910e8e2d424546b72a333 (diff)
gentoo resync : 25.09.2019
Diffstat (limited to 'dev-libs/libfilezilla/libfilezilla-0.18.2.ebuild')
-rw-r--r--dev-libs/libfilezilla/libfilezilla-0.18.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/libfilezilla/libfilezilla-0.18.2.ebuild b/dev-libs/libfilezilla/libfilezilla-0.18.2.ebuild
new file mode 100644
index 000000000000..7ed54fcee7d1
--- /dev/null
+++ b/dev-libs/libfilezilla/libfilezilla-0.18.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic
+
+DESCRIPTION="C++ library offering some basic functionality for platform-independent programs"
+HOMEPAGE="https://lib.filezilla-project.org/"
+SRC_URI="https://download.filezilla-project.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-libs/nettle:0=
+ >=net-libs/gnutls-3.5.7:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cppunit )"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if ! test-flag-CXX -std=c++14; then
+ eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
+ eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
+ eerror "to gcc-4.9 or an equivalent version supporting C++14."
+ die "Currently active compiler does not support -std=c++14"
+ fi
+ fi
+}
+
+src_install() {
+ default
+ find "${ED}" -type f \( -name "*.a" -o -name "*.la" \) -delete || die
+}