summaryrefslogtreecommitdiff
path: root/dev-libs/libezV24/libezV24-0.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libezV24/libezV24-0.1.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libezV24/libezV24-0.1.1.ebuild')
-rw-r--r--dev-libs/libezV24/libezV24-0.1.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/libezV24/libezV24-0.1.1.ebuild b/dev-libs/libezV24/libezV24-0.1.1.ebuild
new file mode 100644
index 000000000000..db6b724d1f4c
--- /dev/null
+++ b/dev-libs/libezV24/libezV24-0.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="library that provides an easy API to Linux serial ports"
+HOMEPAGE="http://ezv24.sourceforge.net"
+SRC_URI="mirror://sourceforge/ezv24/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc sparc x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-test.patch
+ sed -i -e 's:__LINUX__:__linux__:' *.c *.h
+}
+
+src_compile() {
+ tc-export AR CC RANLIB
+ emake || die "emake failed."
+}
+
+src_install() {
+ export NO_LDCONFIG="stupid"
+ emake DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" \
+ install || die "emake install failed."
+ dodoc AUTHORS BUGS ChangeLog HISTORY README
+ dohtml api-html/*
+}