summaryrefslogtreecommitdiff
path: root/dev-libs/libevdev/libevdev-1.5.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-31 20:30:04 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-31 20:30:04 +0000
commit4650985dd0e898b82e0d2ec225931297d4fadccf (patch)
treeeb0e8002cf3ebf1009110b6fec47fa90f873d824 /dev-libs/libevdev/libevdev-1.5.8.ebuild
parent67f76a858f1ac826bd8a550d756d9ec6e340ed4f (diff)
gentoo resync : 31.01.2018
Diffstat (limited to 'dev-libs/libevdev/libevdev-1.5.8.ebuild')
-rw-r--r--dev-libs/libevdev/libevdev-1.5.8.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/libevdev/libevdev-1.5.8.ebuild b/dev-libs/libevdev/libevdev-1.5.8.ebuild
new file mode 100644
index 000000000000..8b9f30261c7b
--- /dev/null
+++ b/dev-libs/libevdev/libevdev-1.5.8.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+XORG_MULTILIB=yes
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit python-any-r1 xorg-2
+
+EGIT_REPO_URI="https://anongit.freedesktop.org/git/libevdev.git"
+
+DESCRIPTION="Handler library for evdev events"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libevdev/"
+
+if [[ ${PV} == 9999* ]] ; then
+ SRC_URI=""
+else
+ SRC_URI="https://www.freedesktop.org/software/libevdev/${P}.tar.xz"
+fi
+
+RESTRICT="test" # Tests need to run as root.
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"