summaryrefslogtreecommitdiff
path: root/dev-libs/libevdev/libevdev-1.13.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-06 08:09:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-06 08:09:34 +0100
commitda3552023d9aae2ee5183df71a80a8169414974e (patch)
treed26518a0f3fb7b5f62d9fa5f546757d405f4d380 /dev-libs/libevdev/libevdev-1.13.0.ebuild
parent51f0d16e058c162dbce0f93d871ba45683b0ab3a (diff)
gentoo auto-resync : 06:08:2022 - 08:09:34
Diffstat (limited to 'dev-libs/libevdev/libevdev-1.13.0.ebuild')
-rw-r--r--dev-libs/libevdev/libevdev-1.13.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/libevdev/libevdev-1.13.0.ebuild b/dev-libs/libevdev/libevdev-1.13.0.ebuild
new file mode 100644
index 000000000000..9f3d0d16e6a3
--- /dev/null
+++ b/dev-libs/libevdev/libevdev-1.13.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit meson-multilib python-any-r1
+
+DESCRIPTION="Handler library for evdev events"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libevdev/ https://gitlab.freedesktop.org/libevdev/libevdev"
+
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/libevdev/libevdev.git"
+ inherit git-r3
+else
+ SRC_URI="https://www.freedesktop.org/software/libevdev/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc test"
+
+DEPEND="test? ( dev-libs/check[${MULTILIB_USEDEP}] )"
+BDEPEND="
+ ${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig
+"
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_feature doc documentation)
+ $(meson_feature test tests)
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ meson_src_test -t 100
+}
+
+multilib_src_install_all() {
+ if use doc; then
+ local HTML_DOCS=( doc/html/. )
+ einstalldocs
+ fi
+}