summaryrefslogtreecommitdiff
path: root/dev-libs/libelf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libelf
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libelf')
-rw-r--r--dev-libs/libelf/Manifest4
-rw-r--r--dev-libs/libelf/files/libelf-0.8.13-build.patch38
-rw-r--r--dev-libs/libelf/libelf-0.8.13-r2.ebuild50
-rw-r--r--dev-libs/libelf/metadata.xml8
4 files changed, 100 insertions, 0 deletions
diff --git a/dev-libs/libelf/Manifest b/dev-libs/libelf/Manifest
new file mode 100644
index 000000000000..f3a5430cca23
--- /dev/null
+++ b/dev-libs/libelf/Manifest
@@ -0,0 +1,4 @@
+AUX libelf-0.8.13-build.patch 1358 BLAKE2B b0a6ea3d29cc508da873b9dcb9c99c171e01d47df4f6c753434f9da04f18aa56314df089fd2dfebca320645a99fa474359f731d315d51989041ccdc4eb997460 SHA512 7971ef661c058d092c7d5c89649c9abdec1b9fea45bb71f442d5a671a754f793b54674a7665614551067733f1c415c4e05be99c7714d78488eb19850a409f98c
+DIST libelf-0.8.13.tar.gz 148529 BLAKE2B c0364d6a155ec1590c8ef0754ff0989144d2331e99eb2a5208d80259229904a72328733460675e334ce6b26123f1c92d28d5fb9aea1acdff3ea7a16f4b572a09 SHA512 d2a4ea8ccc0bbfecac38fa20fbd96aefa8e86f8af38691fb6991cd9c5a03f587475ecc2365fc89a4954c11a679d93460ee9a5890693112f6133719af3e6582fe
+EBUILD libelf-0.8.13-r2.ebuild 1308 BLAKE2B 3f72706dbcec0560974fba8ebdcfa517d24a590f132924a2bd12e0720e59d4d0fb5d71b2cdf7e2ed57588fc65b3a4c1fc83f4698ec0997bf5bed2cbe1d365078 SHA512 1d72392eeb763883c68a10c3ec2bfd18d9546e00510672f4587f0a4c4e69aed54773021ed81255195e3e5494a4dc9c8c453c6d2191cefd9e3e8b1e7c35224931
+MISC metadata.xml 252 BLAKE2B f6282e2a99df668246ea8570c72345463f06d282b6adc6d9de2a08ef0827cf4572332c580caa594aad5ba8e200870d8d25494549ee4413798025f0d885b61a68 SHA512 cbda7bf9832872764ae776ce16b2966c37a2ba3a1982d9817006fd6b82d7b17146434cde428bf114062a483e9053d2acdcdd004695e6ebf428d19cdc09937c65
diff --git a/dev-libs/libelf/files/libelf-0.8.13-build.patch b/dev-libs/libelf/files/libelf-0.8.13-build.patch
new file mode 100644
index 000000000000..7e0cce6384d9
--- /dev/null
+++ b/dev-libs/libelf/files/libelf-0.8.13-build.patch
@@ -0,0 +1,38 @@
+Index: libelf-0.8.13/aclocal.m4
+===================================================================
+--- libelf-0.8.13.orig/aclocal.m4
++++ libelf-0.8.13/aclocal.m4
+@@ -235,7 +235,7 @@ AC_DEFUN(mr_ENABLE_SHARED, [
+ AC_REQUIRE([AC_PROG_CC])
+ AC_PATH_PROG(LD, ld, ld)
+ case "$host" in
+- *-linux*|*-gnu*)
++ *-linux*|*-gnu*|*-freebsd*|*-solaris*)
+ if test "$GCC" = yes; then
+ mr_TARGET_ELF
+ if test "$mr_cv_target_elf" = yes; then
+Index: libelf-0.8.13/lib/Makefile.in
+===================================================================
+--- libelf-0.8.13.orig/lib/Makefile.in
++++ libelf-0.8.13/lib/Makefile.in
+@@ -158,7 +158,7 @@ libelf.a: $(OBJS) $(LIBOBJS)
+
+ $(SHLIB): libelf.a
+ @$(RM) $(SHLIB)
+- $(LINK_SHLIB) -o $(SHLIB) $(OBJS:.o=.os) $(LIBOBJS:.o=.os) $(DEPSHLIBS)
++ $(LINK_SHLIB) $(LDFLAGS) -o $(SHLIB) $(OBJS:.o=.os) $(LIBOBJS:.o=.os) $(DEPSHLIBS)
+ if test "$(SONAME)" = "$(SHLIB)"; then true; else \
+ $(RM) $(SONAME) && $(LN_S) $(SHLIB) $(SONAME); \
+ fi
+@@ -169,9 +169,9 @@ $(SHLIB): libelf.a
+ install: install-data \
+ install-shared-$(DO_SHLIB) install-compat-$(DO_COMPAT)
+
+-installdirs: $(top_srcdir)/mkinstalldirs
++installdirs:
+ dirs="$(installdirs)"; for dir in $$dirs; do \
+- $(SHELL) $(top_srcdir)/mkinstalldirs $(instroot)$$dir; \
++ mkdir -p $(instroot)$$dir; \
+ done
+
+ install-data: all installdirs
diff --git a/dev-libs/libelf/libelf-0.8.13-r2.ebuild b/dev-libs/libelf/libelf-0.8.13-r2.ebuild
new file mode 100644
index 000000000000..98d0962d4f44
--- /dev/null
+++ b/dev-libs/libelf/libelf-0.8.13-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils multilib autotools multilib-minimal
+
+DESCRIPTION="A ELF object file access library"
+HOMEPAGE="http://www.mr511.de/software/"
+SRC_URI="http://www.mr511.de/software/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ~mips ppc ppc64 sparc x86 -amd64-fbsd -x86-fbsd ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug nls elibc_FreeBSD"
+
+RDEPEND="!dev-libs/elfutils"
+DEPEND="nls? ( sys-devel/gettext )"
+
+DOCS=( ChangeLog README )
+MULTILIB_WRAPPED_HEADERS=( /usr/include/libelf/sys_elf.h )
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-build.patch"
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # prefix might want to play with this; unfortunately the stupid
+ # macro used to detect whether we're building ELF is so screwed up
+ # that trying to fix it is just a waste of time.
+ export mr_cv_target_elf=yes
+
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable nls) \
+ --enable-shared \
+ $(use_enable debug)
+}
+
+multilib_src_install() {
+ emake \
+ prefix="${ED}usr" \
+ libdir="${ED}usr/$(get_libdir)" \
+ install \
+ install-compat \
+ -j1 || die
+
+ # Stop libelf from stamping on the system nlist.h
+ use elibc_FreeBSD && rm "${ED}"/usr/include/nlist.h
+}
diff --git a/dev-libs/libelf/metadata.xml b/dev-libs/libelf/metadata.xml
new file mode 100644
index 000000000000..d920e3ba3e56
--- /dev/null
+++ b/dev-libs/libelf/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+</pkgmetadata>