summaryrefslogtreecommitdiff
path: root/dev-libs/libebml/libebml-1.3.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-18 18:58:09 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-18 18:58:09 +0000
commit6ec19c7f1bc4aa70e5f8a86cd29d579a95d97035 (patch)
tree860348d8573f52d9ddf8a87c31099b8bb3a04806 /dev-libs/libebml/libebml-1.3.10.ebuild
parent1118729405d206538433388e0a8bd578f7ae7303 (diff)
gentoo resync : 18.01.2020
Diffstat (limited to 'dev-libs/libebml/libebml-1.3.10.ebuild')
-rw-r--r--dev-libs/libebml/libebml-1.3.10.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-libs/libebml/libebml-1.3.10.ebuild b/dev-libs/libebml/libebml-1.3.10.ebuild
new file mode 100644
index 000000000000..dbb462d75acb
--- /dev/null
+++ b/dev-libs/libebml/libebml-1.3.10.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Extensible binary format library (kinda like XML)"
+HOMEPAGE="https://www.matroska.org/ https://github.com/Matroska-Org/libebml/"
+SRC_URI="https://dl.matroska.org/downloads/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/4" # subslot = soname major version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=YES )
+ cmake_src_configure
+}