summaryrefslogtreecommitdiff
path: root/dev-libs/libdnsres
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libdnsres
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libdnsres')
-rw-r--r--dev-libs/libdnsres/Manifest4
-rw-r--r--dev-libs/libdnsres/files/libdnsres-0.1a-autotools.patch28
-rw-r--r--dev-libs/libdnsres/libdnsres-0.1a-r2.ebuild25
-rw-r--r--dev-libs/libdnsres/metadata.xml17
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-libs/libdnsres/Manifest b/dev-libs/libdnsres/Manifest
new file mode 100644
index 000000000000..0676d342bc0a
--- /dev/null
+++ b/dev-libs/libdnsres/Manifest
@@ -0,0 +1,4 @@
+AUX libdnsres-0.1a-autotools.patch 1020 BLAKE2B 456ef2ebd3f4b12181819366503e5297710f12e7cdf7270f5a0df14cea43271bdd499a93c1eb3acda32a094b87c4fec471027b197e34524830f1a6f64640d529 SHA512 12709a918aaaf135f9cdacac52fed2d6ec29a171d2474f375e1a014158c98fbcd2d1b498162e1e1ccd1b78461df796c88c876253c4a0747a9b4ae428634c4708
+DIST libdnsres-0.1a.tar.gz 360583 BLAKE2B b2b3befaf3910b46e826c17ec36bb90271b334a58ef5d02bd69ad0aa8643e2fe8ab4a1f86b59e4fbd1d41ef2c01ea01995b07b68922740fc86bee3d207bcc65d SHA512 d6b1c248a99eeaea3524ee8af01dd31ba507179a69ffb313a167611792084d5efc99fe6462a63480932faa3493b01c3c43fc7575dab6aaade885583bee006f67
+EBUILD libdnsres-0.1a-r2.ebuild 568 BLAKE2B b40135288d0292a597e889576f0a282e58782f5da79b845a618d2710b86ff5c938b51c34d36cce6709fc30c9ad496a89d61efe71eccc1699a9ad41c3843404d9 SHA512 c2148ee736a8dffba14ada064dcc2664f782c201c40f4295c1cbaec9e978218ee5003f6976646755985cf379c1ab6f42f78273cabe90323fd40ae03176097c23
+MISC metadata.xml 821 BLAKE2B fe11fa4932033b3bdbe6f7b55495aca6a1ff5d745fa65654d42ac0dc3b5992a7cf91cc705113b4a2c3ea04c0384589cd4f75c2c4d496b834db664313be30f711 SHA512 cbb9306da8e15d166cdd09e0bf6e8a07030a12d45bda18d56f45b18e439c6e199963189047fe846dd59b33408de6a101ecb1a7c251cfb5dc5c34cc313a741134
diff --git a/dev-libs/libdnsres/files/libdnsres-0.1a-autotools.patch b/dev-libs/libdnsres/files/libdnsres-0.1a-autotools.patch
new file mode 100644
index 000000000000..3e2466af57f7
--- /dev/null
+++ b/dev-libs/libdnsres/files/libdnsres-0.1a-autotools.patch
@@ -0,0 +1,28 @@
+Index: libdnsres-0.1a/Makefile.am
+===================================================================
+--- libdnsres-0.1a.orig/Makefile.am
++++ libdnsres-0.1a/Makefile.am
+@@ -10,12 +10,12 @@ libdnsres_la_SOURCES = res_comp.c res_de
+ res_data.c res_init.c res_query.c res_send.c resolv.h dnsres.h \
+ gethostnamadr.c getaddrinfo.c getservbyname.c getservent.c base64.c \
+ dnsres-internal.h
+-libdnsres_la_LIBADD = @LIBOBJS@
++libdnsres_la_LIBADD = @LTLIBOBJS@
+ libdnsres_la_LDFLAGS = -version-info 0:1:0
+
+ include_HEADERS = dnsres.h
+
+-CFLAGS = -Wall -O0 -g -DRESOLVSORT
++AM_CFLAGS = -Wall -g -DRESOLVSORT
+ INCLUDES = -I$(top_srcdir)/compat @EVENTINC@
+
+ man_MANS = dnsres.3
+@@ -23,7 +23,7 @@ man_MANS = dnsres.3
+ noinst_PROGRAMS = simple_test
+ simple_test_SOURCES = test/simple_test.c
+ simple_test_INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/compat @EVENTINC@
+-simple_test_LDADD = -L$(top_buildir) -ldnsres @EVENTLIB@
++simple_test_LDADD = libdnsres.la @EVENTLIB@
+
+ verify: libdnsres.a
+ cd $(srcdir)/test && make verify
diff --git a/dev-libs/libdnsres/libdnsres-0.1a-r2.ebuild b/dev-libs/libdnsres/libdnsres-0.1a-r2.ebuild
new file mode 100644
index 000000000000..2811d24833bf
--- /dev/null
+++ b/dev-libs/libdnsres/libdnsres-0.1a-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="A non-blocking DNS resolver library"
+HOMEPAGE="https://www.monkey.org/~provos/libdnsres/"
+SRC_URI="https://www.monkey.org/~provos/${P}.tar.gz"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="amd64 ~ppc sparc x86"
+
+DEPEND="dev-libs/libevent"
+RDEPEND="${DEPEND}"
+
+DOCS=( README )
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-autotools.patch"
+ sed -i configure.in -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
+ eautoreconf
+}
diff --git a/dev-libs/libdnsres/metadata.xml b/dev-libs/libdnsres/metadata.xml
new file mode 100644
index 000000000000..30908933eb68
--- /dev/null
+++ b/dev-libs/libdnsres/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>netmon@gentoo.org</email>
+ <name>Gentoo network monitoring and analysis project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Libdnsres provides a non-blocking thread-safe API for resolving DNS names.
+ It requires that your main application is built on top of libevent.
+ Libdnsres' API essentially mirrors the traditional gethostbyname and
+ getaddrinfo interfaces. All return values have been replaced by callbacks
+ instead. The code borrows heavily from the BSD resolver library. In fact, it
+ is an extremely ugly hack to make the BSD resolver library non-blocking and
+ thread-safe without changing the API too much.
+ </longdescription>
+</pkgmetadata>