summaryrefslogtreecommitdiff
path: root/dev-libs/libdnsres/libdnsres-0.1a-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-libs/libdnsres/libdnsres-0.1a-r3.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-libs/libdnsres/libdnsres-0.1a-r3.ebuild')
-rw-r--r--dev-libs/libdnsres/libdnsres-0.1a-r3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/libdnsres/libdnsres-0.1a-r3.ebuild b/dev-libs/libdnsres/libdnsres-0.1a-r3.ebuild
new file mode 100644
index 000000000000..99fa34502800
--- /dev/null
+++ b/dev-libs/libdnsres/libdnsres-0.1a-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="A non-blocking DNS resolver library"
+HOMEPAGE="https://www.monkey.org/~provos/libdnsres/"
+SRC_URI="https://www.monkey.org/~provos/${P}.tar.gz"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="static-libs"
+
+DEPEND="dev-libs/libevent"
+RDEPEND="${DEPEND}"
+
+DOCS=( README )
+PATCHES=(
+ "${FILESDIR}"/${P}-autotools.patch
+)
+
+src_prepare() {
+ default
+ sed -i configure.in -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}