summaryrefslogtreecommitdiff
path: root/dev-libs/libdnet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libdnet
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libdnet')
-rw-r--r--dev-libs/libdnet/Manifest4
-rw-r--r--dev-libs/libdnet/libdnet-1.12.ebuild70
-rw-r--r--dev-libs/libdnet/metadata.xml12
3 files changed, 86 insertions, 0 deletions
diff --git a/dev-libs/libdnet/Manifest b/dev-libs/libdnet/Manifest
new file mode 100644
index 000000000000..13662b597453
--- /dev/null
+++ b/dev-libs/libdnet/Manifest
@@ -0,0 +1,4 @@
+DIST libdnet-1.12.ipv6-1.patch.gz 5124 BLAKE2B 674866a441a5907df97942772b1e4b95aee004ddb110204df0580cec6b6bb3ba4074831d83e675e1914f1a29281b02227e95016db6ce6a0e8b99417d1aa6aaab SHA512 fa2380e41548ecdd978722930ecf90dffabd15cf06cbae0e113285072fe98a066f1e686b6d79e2d8b9f8adcf29783f313d61933b9e1e74e71da8dc7d741f815a
+DIST libdnet-1.12.tgz 970125 BLAKE2B 74be00b6fe1c7848010a7044628a6ad8f4b2f2c4f9676066c15e02c7a8b613e26a5e7743df524869fee2eb7d93438bf346f772b8df199b8ec337279dd50d5d77 SHA512 b763d2caa77b8d16b531142a5bce3b862ed20198406a00e1fe7f3b45ce308b97d638b0c7f03bd8593fdd206cc1645952839bc340b77537298a3df88599835bf3
+EBUILD libdnet-1.12.ebuild 1523 BLAKE2B 9f05030b1d32ca80bffd7a4eefeb9d55ffefe9ac2bde8bec41782c1a0a96fe2fe4cd164c94ef184c591fc998dabff1a091235d9584e23dfdb41c94a44e9b7942 SHA512 0128a0f669d3ce291b65e71b725b8f8e66934df2bd0036d96fd288a03047344921e038204cb44a6db781bc07c28e38a84c785efdd84b255dd68ca607e7b8ab10
+MISC metadata.xml 412 BLAKE2B 31f4ab6e16ecdf55347cc83250bc3ce8afc9305f27b1925fe231cc66945725fd33d8239265e6219caf822ef23501014a85219d2a222f5085881b7ca06dffdafc SHA512 ba32dc96871e434caec3a21dea3c5f005c4aacf122312dcd44a228ae92c02c90c02339761ea091fbcad618b02cd5e4d672914c5b6263ef386d49242e19e1febe
diff --git a/dev-libs/libdnet/libdnet-1.12.ebuild b/dev-libs/libdnet/libdnet-1.12.ebuild
new file mode 100644
index 000000000000..d1269f770acb
--- /dev/null
+++ b/dev-libs/libdnet/libdnet-1.12.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AT_M4DIR="config"
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_OPTIONAL=1
+
+inherit autotools distutils-r1 eutils
+
+DESCRIPTION="simplified, portable interface to several low-level networking routines"
+HOMEPAGE="https://github.com/dugsong/libdnet"
+SRC_URI="https://libdnet.googlecode.com/files/${P}.tgz
+ ipv6? ( https://fragroute-ipv6.googlecode.com/files/${P}.ipv6-1.patch.gz )"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="ipv6 python static-libs test"
+
+#DEPEND="test? ( dev-libs/check )"
+DEPEND="python? ( ${PYTHON_DEPS} )"
+RDEPEND="${DEPEND}"
+RESTRICT="test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DOCS=( README THANKS TODO )
+
+src_prepare() {
+ # Useless copy
+ rm -r trunk/ || die
+
+ sed -i \
+ -e 's/libcheck.a/libcheck.so/g' \
+ -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' \
+ configure.in || die
+ sed -i -e 's|-L@libdir@ ||g' dnet-config.in || die
+ use ipv6 && epatch "${WORKDIR}/${P}.ipv6-1.patch"
+ sed -i -e '/^SUBDIRS/s|python||g' Makefile.am || die
+ eautoreconf
+ if use python; then
+ cd python
+ distutils-r1_src_prepare
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_with python) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+ if use python; then
+ cd python
+ distutils-r1_src_compile
+ fi
+}
+
+src_install() {
+ default
+ if use python; then
+ cd python
+ unset DOCS
+ distutils-r1_src_install
+ fi
+ prune_libtool_files
+}
diff --git a/dev-libs/libdnet/metadata.xml b/dev-libs/libdnet/metadata.xml
new file mode 100644
index 000000000000..041d20f37f34
--- /dev/null
+++ b/dev-libs/libdnet/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>netmon@gentoo.org</email>
+ <name>Gentoo network monitoring and analysis project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">libdnet</remote-id>
+ <remote-id type="github">dugsong/libdnet</remote-id>
+ </upstream>
+</pkgmetadata>