summaryrefslogtreecommitdiff
path: root/dev-libs/libdnet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /dev-libs/libdnet
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'dev-libs/libdnet')
-rw-r--r--dev-libs/libdnet/Manifest2
-rw-r--r--dev-libs/libdnet/libdnet-1.14-r2.ebuild (renamed from dev-libs/libdnet/libdnet-9999.ebuild)51
2 files changed, 30 insertions, 23 deletions
diff --git a/dev-libs/libdnet/Manifest b/dev-libs/libdnet/Manifest
index 1a9e7b37ea61..f6cf11f1e6d7 100644
--- a/dev-libs/libdnet/Manifest
+++ b/dev-libs/libdnet/Manifest
@@ -2,5 +2,5 @@ AUX libdnet-1.14-ndisc.patch 18209 BLAKE2B a295d81c247f884293efdf8d4740e2a4fd80c
AUX libdnet-1.14-strlcpy.patch 233 BLAKE2B fb35015b16a206e55cbc1dc39c032dd43f74cc17e173252227707bef616df827c0ce0d7a7e4349ebc442a9198ee8953c45739b03b306ddc2af2753e31a15ebbd SHA512 8cabaf75382537755d79b588b629978d47a4b8e7c4bda22d7098bba09b5b1fec8dabeacb1727a821df2d29040a3e420803ebfdc66df5824630fae8da1059d164
DIST libdnet-1.14.tar.gz 520833 BLAKE2B 97e241fc374fc9489e70d440db5e19199f4e653650af85e24af56bbbc0167db1c451349c43fcb630a26c61f8ca15c58f5c879e0d82654e275189ca3e140bb22a SHA512 ce8d95228f5175e4d9a8ff71bb99eb1ccc3ccd599a85dd07adbfd9842fc54066235d362c8060828fb3ba8129d0e1e8e071e93d60d69c6d03be310c80e61cea93
EBUILD libdnet-1.14-r1.ebuild 1484 BLAKE2B b1590fce22cfa777bceb5f6e795862fc6516fce3800ed00fbee91ce1926d18faffb5b2e385a98f6942c0e1e8ec92e95af53ee7f9c3e01e3d7643ce36c4b6326c SHA512 15fc2146d759a143b281936bc7e1c3c1e71e1959dc4354a924f9aafae8bda8b2e140234c0f23aa88c007c4ba5d12a08fabb0806998a1d8c44eb699548b8e91fd
-EBUILD libdnet-9999.ebuild 1376 BLAKE2B 9b8e58f34258ff145a513a3758b458e69cf6dce876b9488648c81c75a5ea074044bdec2494b86f40ca1ee8f4738e4a294530e45d61f56b9b3b1037c118287f2f SHA512 8b59231e80d511ff5bb59bdb750daf2713379358889805625a81e06b3481b031586fa2cb4aa7d959a6e75960edb7a4628c9fc833f1d4814b643cc91d62a5637d
+EBUILD libdnet-1.14-r2.ebuild 1555 BLAKE2B bec848308e89e072cc5f787a54855b280e05c5c8ec94ded0ac8eb6f58bfa2f45878a4c8477fe624c428183e8a680a70a7eb602a644ad5670a54b77db00c5fbea SHA512 4cbd8d00bb5bc8178f921184b4a19f47d0129f4c8561c89464b20afa39beeab002fb5ff79faaa4ffb92f3089ee186c6ec2373c25934bc7f8d6b0a9927289a77c
MISC metadata.xml 412 BLAKE2B 31f4ab6e16ecdf55347cc83250bc3ce8afc9305f27b1925fe231cc66945725fd33d8239265e6219caf822ef23501014a85219d2a222f5085881b7ca06dffdafc SHA512 ba32dc96871e434caec3a21dea3c5f005c4aacf122312dcd44a228ae92c02c90c02339761ea091fbcad618b02cd5e4d672914c5b6263ef386d49242e19e1febe
diff --git a/dev-libs/libdnet/libdnet-9999.ebuild b/dev-libs/libdnet/libdnet-1.14-r2.ebuild
index c1471b35968c..2938cfe88b82 100644
--- a/dev-libs/libdnet/libdnet-9999.ebuild
+++ b/dev-libs/libdnet/libdnet-1.14-r2.ebuild
@@ -1,33 +1,38 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
AT_M4DIR="config"
PYTHON_COMPAT=( python3_{6,7,8} )
DISTUTILS_OPTIONAL=1
-inherit autotools distutils-r1 git-r3
+inherit autotools distutils-r1
DESCRIPTION="simplified, portable interface to several low-level networking routines"
HOMEPAGE="https://github.com/ofalk/libdnet"
-EGIT_REPO_URI="https://github.com/ofalk/libdnet"
-EGIT_BRANCH="devel"
-LICENSE="LGPL-2"
+SRC_URI="https://github.com/ofalk/${PN}/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS=""
-IUSE="python static-libs test"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="python test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
-DEPEND="
- python? ( ${PYTHON_DEPS} )
-"
-RDEPEND="
- ${DEPEND}
+DEPEND="python? ( ${PYTHON_DEPS} )"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ python? (
+ dev-python/cython[${PYTHON_USEDEP}]
+ )
"
-RESTRICT="test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-DOCS=( README.md THANKS TODO )
+
+DOCS=( README.md THANKS )
+
PATCHES=(
- "${FILESDIR}"/${PN}-1.14-strlcpy.patch
+ "${FILESDIR}/${PN}-1.14-ndisc.patch"
+ "${FILESDIR}/${PN}-1.14-strlcpy.patch"
)
src_prepare() {
@@ -47,31 +52,33 @@ src_prepare() {
eautoreconf
if use python; then
- cd python
+ cd python || die
distutils-r1_src_prepare
fi
}
src_configure() {
econf \
- $(use_with python) \
- $(use_enable static-libs static)
+ --disable-static \
+ $(use_with python)
}
src_compile() {
default
if use python; then
- cd python
+ cd python || die
distutils-r1_src_compile
fi
}
src_install() {
default
+
if use python; then
- cd python
+ cd python || die
unset DOCS
distutils-r1_src_install
fi
- find "${D}" -name '*.la' -delete || die
+
+ find "${ED}" -name '*.la' -delete || die
}