summaryrefslogtreecommitdiff
path: root/dev-libs/libdaemon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-09 10:40:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-09 10:40:04 +0100
commitb426a5cef3f0ebe3389686a1c145a834d3a1e120 (patch)
treeeee77f741af6979f620416c573e5203eab81c9c3 /dev-libs/libdaemon
parent97b176c73aa78bd33234884388e3978f520161c3 (diff)
gentoo auto-resync : 09:09:2022 - 10:40:04
Diffstat (limited to 'dev-libs/libdaemon')
-rw-r--r--dev-libs/libdaemon/Manifest2
-rw-r--r--dev-libs/libdaemon/libdaemon-0.14-r4.ebuild (renamed from dev-libs/libdaemon/libdaemon-0.14-r3.ebuild)43
2 files changed, 19 insertions, 26 deletions
diff --git a/dev-libs/libdaemon/Manifest b/dev-libs/libdaemon/Manifest
index 05eb9b86ff96..da11b94aae48 100644
--- a/dev-libs/libdaemon/Manifest
+++ b/dev-libs/libdaemon/Manifest
@@ -1,4 +1,4 @@
AUX 0.14-man-page-typo-fix.patch 1562 BLAKE2B 3e0bc53ca9cbe959ba6360c6226ee99a822bdd78918791bdcf367775d9f80a9bfcf7e82dcd3b4f45c4f10af31be1bacf4ecdbe119482ac6ee705d99967cf9826 SHA512 19aafe2b9d39484ad01544ad3c7937d98b0e8216de1ed8cd331106004f565a6c094888f1a0fd1f540c790728274079343d5db060a0e1a9647d600cea675994d1
DIST libdaemon-0.14.tar.gz 340474 BLAKE2B 1dd6ac48e7b9a31f58688c7a59814435059287a30db80dd7c9cf69f9eaba27245424ecdbfd8719a4cf30d9686f4b61bb5e394821f66c05e770c244a0208e8f3f SHA512 a96b25c09bd63cc192c1c5f8b5bf34cc6ad0c32d42ac14b520add611423b6ad3d64091a47e0c7ab9a94476a5e645529abccea3ed6b23596567163fba88131ff2
-EBUILD libdaemon-0.14-r3.ebuild 1439 BLAKE2B a2e4bf02203e21bd62bf8249b962b4081771791c8c9c546933ee80ab1b32c0bb68a08a39d449100d5d2d5dfb474da9493a4482d93ffeba7e2fd088f13f58643e SHA512 d16ceda7c373a297e64cbb5742303bc886b5b565d13928bf0ab1ef5a66974a9138a47a591793b7849a575f1647041eb5d9b89994c8807c68eac22e68c9a0bcc3
+EBUILD libdaemon-0.14-r4.ebuild 1186 BLAKE2B 009ee728c2eeb1a9500a5a485e7822ba9362f7b7b112ecb9debcc4b7b9309ee1bc9dc3444e81e0945313c1d60c9e9f5170b241e1e853870660d912c39e19339d SHA512 b21321cbbf195ed6837b9456ee2dd9c731d79fd57d81f7bd63f7993c1bbad967d5f7ac6ec8a67793a15c7faae06fb928abc45812da4e8e5c39ca0957a1f902f9
MISC metadata.xml 264 BLAKE2B d8719650b7f42f0fd73819de2c5bea03b775280ea9d8442332f5a47c48d15ecdb91e085f0c9e4d22b0c3850b0049efc0f169a1e147fb21d3ae9b0987b99ee82c SHA512 644fe886ad7c42724a4a622cce4e716461a751eea6307cb04a6a070d3cf5beb46f30c159539b008fcbbee5afbbbc8a4182df448d12b842b30c41f868c7a60e5e
diff --git a/dev-libs/libdaemon/libdaemon-0.14-r3.ebuild b/dev-libs/libdaemon/libdaemon-0.14-r4.ebuild
index 6e38f45fae5b..30beecfa0faa 100644
--- a/dev-libs/libdaemon/libdaemon-0.14-r3.ebuild
+++ b/dev-libs/libdaemon/libdaemon-0.14-r4.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools multilib-minimal
+inherit autotools
DESCRIPTION="Simple library for creating daemon processes in C"
HOMEPAGE="http://0pointer.de/lennart/projects/libdaemon/"
@@ -12,7 +12,7 @@ SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0/5"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="doc examples static-libs"
+IUSE="doc examples"
BDEPEND="doc? ( app-doc/doxygen )"
@@ -27,40 +27,33 @@ src_prepare() {
# (elibtoolize is insufficient)
# bug #668404
eautoreconf
-
- # doxygen is broken with out-of-source builds
- multilib_copy_sources
}
-multilib_src_configure() {
- econf \
- --localstatedir=/var \
- --disable-examples \
- --disable-lynx \
- $(use_enable static-libs static)
+src_configure() {
+ local myeconfargs=(
+ --localstatedir="${EPREFIX}"/var
+ --disable-examples
+ --disable-lynx
+ )
+
+ econf "${myeconfargs[@]}"
}
-multilib_src_compile() {
+src_compile() {
emake
- if multilib_is_native_abi && use doc; then
+ if use doc; then
einfo "Building documentation"
emake doxygen
- fi
-}
-multilib_src_install() {
- emake DESTDIR="${D}" install
-
- if multilib_is_native_abi && use doc; then
- docinto html
- dodoc -r doc/README.html doc/style.css doc/reference/html/*
- doman doc/reference/man/man3/*.h.3
+ HTML_DOCS=( doc/README.html doc/style.css doc/reference/html/. )
fi
}
-multilib_src_install_all() {
- einstalldocs
+src_install() {
+ default
+
+ use doc && doman doc/reference/man/man3/*.h.3
find "${ED}" -name '*.la' -delete || die