summaryrefslogtreecommitdiff
path: root/dev-libs/libcxml/libcxml-0.15.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-02 14:13:35 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-02 14:13:35 +0100
commit7c7c2c9727d6b2ff30945b5aea0d575e1c406d8b (patch)
treebac2a67fb24ac0836147fe370d30e1610ae1845d /dev-libs/libcxml/libcxml-0.15.5.ebuild
parent2f8db31405fac68eea6f7257d58529243815033b (diff)
gentoo resync : 02.05.2018
Diffstat (limited to 'dev-libs/libcxml/libcxml-0.15.5.ebuild')
-rw-r--r--dev-libs/libcxml/libcxml-0.15.5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/libcxml/libcxml-0.15.5.ebuild b/dev-libs/libcxml/libcxml-0.15.5.ebuild
new file mode 100644
index 000000000000..c2f81a9bc6cb
--- /dev/null
+++ b/dev-libs/libcxml/libcxml-0.15.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+PYTHON_REQ_USE="threads(+)"
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="small C++ library which makes it marginally neater to parse XML using libxml++"
+HOMEPAGE="http://carlh.net/libcxml"
+SRC_URI="http://carlh.net/downloads/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-cpp/libxmlpp:2.6
+ dev-libs/boost
+ dev-libs/locked_sstream"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-util/waf
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.15.5-respect-cxxflags.patch )
+
+src_prepare() {
+ rm -v waf || die
+ export WAF_BINARY="${EROOT}usr/bin/waf"
+
+ default
+}
+
+src_test() {
+ ./run-tests.sh || die
+}