summaryrefslogtreecommitdiff
path: root/dev-libs/libcpuid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-28 21:15:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-28 21:15:05 +0100
commitbd7d7f7f69423122e08209eefb1a8fa1d363e35e (patch)
tree0e400772206f4eb6774b2790628119c0f89ffd49 /dev-libs/libcpuid
parente4faa07b4eb2f5e4f9756d33924b318b1349956a (diff)
gentoo auto-resync : 28:09:2022 - 21:15:04
Diffstat (limited to 'dev-libs/libcpuid')
-rw-r--r--dev-libs/libcpuid/Manifest2
-rw-r--r--dev-libs/libcpuid/libcpuid-0.6.0.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/libcpuid/Manifest b/dev-libs/libcpuid/Manifest
index 00cfd5867777..ec94a66e6921 100644
--- a/dev-libs/libcpuid/Manifest
+++ b/dev-libs/libcpuid/Manifest
@@ -1,3 +1,5 @@
DIST libcpuid-0.5.1.tar.gz 166522 BLAKE2B 3471c11bbe4b0eaac7b00ac20a27556a95991f1b678269ae6f142a0fe2db066ebb756722ae2e76f95158742c93e29a35da6e735226d32b746034acae3ec2a5b7 SHA512 d725bc82e5aa2db69cea7b3590afbe11d6028cf4802fde8d498b4f1cc6d823e73d71b89a453d81bf996d97b36a71f6c00d0f6e8292b72f2be8a64b5d59c01861
+DIST libcpuid-0.6.0.tar.gz 240709 BLAKE2B 6be56956d17aab774282b3e2be83b02f0180153af9cea665dbf8a8a216b35fd8c030b053184d09ac3946d163943281ecb906134290516d8063380749944339e8 SHA512 9f80f0d45f408d35d9ee657d8f53c99bb14e37d26a8a7b6a914546f0446f83a3d75eb06d261c7708a810ba10ce6fadaef54ba7c94cbf22cd113a9f2210c1a708
EBUILD libcpuid-0.5.1.ebuild 753 BLAKE2B d01fe11a825a7e708f94c0f765921317d1364c535e080848d76581d868a7c383fbacad54a6cd8ce0eced41115ed5db383060d2460b948075fd092bb4b1075bbe SHA512 df249ef974f257d4908b7c770781001903ad83698d02d910d09ceb3d644c89abe90a743861077d5b24b3c00dd26522400c33669778f6f9e3759a3873bd269a06
+EBUILD libcpuid-0.6.0.ebuild 753 BLAKE2B f2868a5e15edb572e13c2e6ce58aeb4d31966fbb73c1e5c6bc2f0730f936438f5019f696cf8e35fa01acca39cb06b0b074f6281251b7ed59a8e11e3c46119a31 SHA512 03beaa05a4d3c7f1b1f268b1c73a7e216040f3b04c8cc68d55212142db2408d39f2089d492047ccbfe1a9945db7849e7e752bff092dcae3deeda620a25ba27a7
MISC metadata.xml 2130 BLAKE2B 729a7382c0d844c94da0f24c0a96d6570fbb75202436298dafe21611c8047ddbf5d1479e5ab73655bfa28af5165bde93028ed662ae2c9c294474958bb6b5ef60 SHA512 62b2bdbeb95b3716b40532658720a63825e54c64f312151dd220070ac84d3a067658fbc69b1804afc00c861ebd4f0f0c389c007b1b70a06ffe1e4a7975bd5f3c
diff --git a/dev-libs/libcpuid/libcpuid-0.6.0.ebuild b/dev-libs/libcpuid/libcpuid-0.6.0.ebuild
new file mode 100644
index 000000000000..c3576366dccf
--- /dev/null
+++ b/dev-libs/libcpuid/libcpuid-0.6.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=(python3_{9..11})
+
+inherit autotools python-any-r1
+
+DESCRIPTION="A small C library for x86 (and x86_64) CPU detection and feature extraction"
+HOMEPAGE="http://libcpuid.sourceforge.net/"
+SRC_URI="https://github.com/anrieff/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD-2"
+SLOT="0/16"
+KEYWORDS="~amd64"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf "$(use_enable static-libs static)"
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+}