summaryrefslogtreecommitdiff
path: root/dev-libs/libconfig/libconfig-1.7.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-01 17:20:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-01 17:20:35 +0100
commita88eb1d9b7042912d196e255eeb20e0c77f6cf47 (patch)
tree291cc788e33b3de8bf1b5e3f1fdddf315f2f5ee7 /dev-libs/libconfig/libconfig-1.7.3.ebuild
parentc3d14fe9accdf0b091e42f26a66ed7626ba8c24b (diff)
gentoo auto-resync : 01:05:2023 - 17:20:35
Diffstat (limited to 'dev-libs/libconfig/libconfig-1.7.3.ebuild')
-rw-r--r--dev-libs/libconfig/libconfig-1.7.3.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/dev-libs/libconfig/libconfig-1.7.3.ebuild b/dev-libs/libconfig/libconfig-1.7.3.ebuild
index 8efd8925734c..12eef715344b 100644
--- a/dev-libs/libconfig/libconfig-1.7.3.ebuild
+++ b/dev-libs/libconfig/libconfig-1.7.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -15,7 +15,8 @@ SRC_URI="https://github.com/hyperrealm/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.g
LICENSE="LGPL-2.1"
SLOT="0/11"
KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~loong ~m68k ~mips ppc ~ppc64 ~riscv ~s390 sparc x86 ~x86-linux"
-IUSE="+cxx static-libs"
+IUSE="+cxx static-libs test"
+RESTRICT="!test? ( test )"
DEPEND="
sys-apps/texinfo
@@ -33,10 +34,14 @@ src_prepare() {
}
multilib_src_configure() {
- econf \
- $(use_enable cxx) \
- $(use_enable static-libs static) \
+ local myeconfargs=(
+ $(use_enable cxx)
+ $(use_enable static-libs static)
+ $(use_enable test tests)
--disable-examples
+ )
+
+ econf "${myeconfargs[@]}"
}
multilib_src_test() {