summaryrefslogtreecommitdiff
path: root/dev-libs/libcharon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-libs/libcharon
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-libs/libcharon')
-rw-r--r--dev-libs/libcharon/Manifest4
-rw-r--r--dev-libs/libcharon/libcharon-4.12.1.ebuild72
-rw-r--r--dev-libs/libcharon/libcharon-4.13.0.ebuild72
3 files changed, 148 insertions, 0 deletions
diff --git a/dev-libs/libcharon/Manifest b/dev-libs/libcharon/Manifest
index c0f4e0ae65e5..492d16244dd7 100644
--- a/dev-libs/libcharon/Manifest
+++ b/dev-libs/libcharon/Manifest
@@ -1,3 +1,7 @@
+DIST libcharon-4.12.1.tar.gz 151783 BLAKE2B 54cac090a924ee086e15fddc0cd2acc8dfbc3dfd2dc91b27ffb1d81a64dcf30a46bf62e2c443d8de46a6f2a02e6d06dc1ea454d19f57f7dd93d5f81a44477dba SHA512 dcc0b89703e36e8f3d508bbda91b6fcc8313ac09c4d5e09cc6f0770ccdde18e421daa7e6b52958c5705dbb6987961635e3e31a61810ba54bf8b842af7afba94d
+DIST libcharon-4.13.0.tar.gz 151775 BLAKE2B f8a8b59b361ffc9b54e0047e0cc3824e2a92cf341aa9664712d020e07e5f2facda6f2d1827998c4af0958a3b05070738a20d93d7723a2f3708e601b70474653c SHA512 cd6e4cd696bcbebe5aa6a53f5222fbb8f982ff21d165adcd8854769b19df2d15ea6287100ba09ddd85ac80d3f86dbfae9ac050ee50f082223bf0acb542413d8c
DIST libcharon-4.9.1.tar.gz 151243 BLAKE2B 8557efe4667a83297a4bcfc8307e2322a379e52d50ad1648d873a923e182b3be1651a13c7402ac041fd134036a75a42e825adf2cc27271af218db44af7e48473 SHA512 41d611f8d3bf0f762a38a00c159104df04b73cd5c4f7e9ebcfe3ac9cdd0c8e31e505c4fd4ef8f8a6f1c02bf882bb3e14ea4e92c8b15169a91cbd1815e36310fa
+EBUILD libcharon-4.12.1.ebuild 1746 BLAKE2B 8398f3a32823f17eb7d7c20da8d6a80c233ca9064d005b585fad25ad42e28cd443165801bfac246424fa2714eb0bf32fc2e7f5811ed55686e3a9c7454979626f SHA512 c3f9a56031cdd4e2f252c68fe7c3fa7f1821775250aea272ca9414f10a344557df872333eea1614cf241abf7379eed7311c25bdc5e7d427dc362101aa2abcc5c
+EBUILD libcharon-4.13.0.ebuild 1747 BLAKE2B 6062f4fed8d330e9e6a28c4e91dcac51bd79fa4e6094e6084e3062002abd83b905b03e9da906c3f6717e82409588dd13237f7e272d3a22594e913198e442b581 SHA512 8b3dac6ae40877e6a24ded839db182e11b3f3c1b163a6cf69f48681b1cd955d39ab6d825a2c4ce97a3db20df29767963c4d8f5e8791873fb1a6281aca2bb585a
EBUILD libcharon-4.9.1-r1.ebuild 1747 BLAKE2B 8a8989c27be14e430a912d220e83e12e7584010a82838ff7453c9f58b7a6e3bb045885a6f222ef49a17fbd77dbbfe7d8343bbeba387008a6f50299d2dc6b4021 SHA512 422fe986046dbb84f3cef7e1e7872a484a8a71dcd49e0dd5d096aa89a60f8c2bba1a2d2ecc5648c88668b3cdfc4a94e0448b9f24c539840244d10a409cac419d
MISC metadata.xml 1140 BLAKE2B 356713d6a644186b8fda5d9fd9587a74a605aaa638217c62dd9f0657859322c66015d25a5b5335dbe02fcf2492ca7dec0d5e7decd5a2d4602b8b8ec8338f7821 SHA512 8aa76c3b4dc2246e0cc6c508149ff9913ef3310a3477d7596b9101f183d0e858cc3c11ebfd138cf1eb65e79c2800ad63cfaca63201aa1a63e36e5ef63bd664aa
diff --git a/dev-libs/libcharon/libcharon-4.12.1.ebuild b/dev-libs/libcharon/libcharon-4.12.1.ebuild
new file mode 100644
index 000000000000..9d4e30e9bfc3
--- /dev/null
+++ b/dev-libs/libcharon/libcharon-4.12.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake python-single-r1
+
+MY_PN="libCharon"
+
+DESCRIPTION="This library facilitates communication between Cura and its backend"
+HOMEPAGE="https://github.com/Ultimaker/libCharon"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~x86"
+
+IUSE="+client +dbus test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RDEPEND="
+ ${PYTHON_DEPS}
+ dbus? (
+ acct-group/ultimaker
+ acct-user/ultimaker
+ sys-apps/dbus
+ )"
+
+DEPEND="${PYTHON_DEPS}
+ test? (
+ $(python_gen_cond_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
+ )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ # use current python version, not the latest installed
+ # fix python install location
+ sed -i \
+ -e "s:find_package(Python3 3.4 REQUIRED:find_package(Python3 ${EPYTHON##python} EXACT REQUIRED:g" \
+ -e "s:lib\${LIB_SUFFIX}/python\${Python3_VERSION_MAJOR}\.\${Python3_VERSION_MINOR}/site-packages:$(python_get_sitedir):g" \
+ CMakeLists.txt || die
+
+ sed -i -e "s:/usr/lib/python3/dist-packages/Charon/Service/main.py:$(python_get_sitedir)/Charon/Service/main.py:g" service/charon.service || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_CLIENT=$(usex client ON OFF)
+ -DINSTALL_SERVICE=$(usex dbus ON OFF)
+ -DPython3_EXECUTABLE="${PYTHON}"
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ python_optimize
+}
+
+pkg_postinst() {
+ if use dbus ; then
+ elog "To start the Charon File Metadata service at boot, add it to the default runlevel with:"
+ elog " systemctl enable charon"
+ fi
+}
diff --git a/dev-libs/libcharon/libcharon-4.13.0.ebuild b/dev-libs/libcharon/libcharon-4.13.0.ebuild
new file mode 100644
index 000000000000..5a215127935d
--- /dev/null
+++ b/dev-libs/libcharon/libcharon-4.13.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake python-single-r1
+
+MY_PN="libCharon"
+
+DESCRIPTION="This library facilitates communication between Cura and its backend"
+HOMEPAGE="https://github.com/Ultimaker/libCharon"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+IUSE="+client +dbus test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RDEPEND="
+ ${PYTHON_DEPS}
+ dbus? (
+ acct-group/ultimaker
+ acct-user/ultimaker
+ sys-apps/dbus
+ )"
+
+DEPEND="${PYTHON_DEPS}
+ test? (
+ $(python_gen_cond_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
+ )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ # use current python version, not the latest installed
+ # fix python install location
+ sed -i \
+ -e "s:find_package(Python3 3.4 REQUIRED:find_package(Python3 ${EPYTHON##python} EXACT REQUIRED:g" \
+ -e "s:lib\${LIB_SUFFIX}/python\${Python3_VERSION_MAJOR}\.\${Python3_VERSION_MINOR}/site-packages:$(python_get_sitedir):g" \
+ CMakeLists.txt || die
+
+ sed -i -e "s:/usr/lib/python3/dist-packages/Charon/Service/main.py:$(python_get_sitedir)/Charon/Service/main.py:g" service/charon.service || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_CLIENT=$(usex client ON OFF)
+ -DINSTALL_SERVICE=$(usex dbus ON OFF)
+ -DPython3_EXECUTABLE="${PYTHON}"
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ python_optimize
+}
+
+pkg_postinst() {
+ if use dbus ; then
+ elog "To start the Charon File Metadata service at boot, add it to the default runlevel with:"
+ elog " systemctl enable charon"
+ fi
+}