summaryrefslogtreecommitdiff
path: root/dev-libs/libcdio-paranoia/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libcdio-paranoia/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libcdio-paranoia/files')
-rw-r--r--dev-libs/libcdio-paranoia/files/libcdio-paranoia-0.90-mkdir_p.patch26
-rw-r--r--dev-libs/libcdio-paranoia/files/libcdio-paranoia-0.90-oos-tests.patch48
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-libs/libcdio-paranoia/files/libcdio-paranoia-0.90-mkdir_p.patch b/dev-libs/libcdio-paranoia/files/libcdio-paranoia-0.90-mkdir_p.patch
new file mode 100644
index 000000000000..98681d0a08fc
--- /dev/null
+++ b/dev-libs/libcdio-paranoia/files/libcdio-paranoia-0.90-mkdir_p.patch
@@ -0,0 +1,26 @@
+http://bugs.gentoo.org/455374
+http://github.com/rocky/libcdio-paranoia/issues/1
+https://savannah.gnu.org/bugs/index.php?38273
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -74,6 +74,8 @@
+ dnl Checks for programs.
+ AC_AIX
+
++AC_PROG_MKDIR_P
++
+ if test "x$GCC" != "xyes"
+ then
+ AC_MSG_WARN([
+--- a/doc/ja/Makefile.am
++++ b/doc/ja/Makefile.am
+@@ -25,7 +25,7 @@
+
+ install-man1: $(man_MANS)
+ @$(NORMAL_INSTALL)
+- test -z "$(man1dir)" || $(mkdir_p) "$(DESTDIR)$(mandir)$(mansubdir)"
++ test -z "$(man1dir)" || $(MKDIR_P) "$(DESTDIR)$(mandir)$(mansubdir)"
+ @list='$(man1_MANS)'; \
+ l2='$(man_MANS)'; for i in $$l2; do \
+ case "$$i" in \
diff --git a/dev-libs/libcdio-paranoia/files/libcdio-paranoia-0.90-oos-tests.patch b/dev-libs/libcdio-paranoia/files/libcdio-paranoia-0.90-oos-tests.patch
new file mode 100644
index 000000000000..86cf9da8d0fd
--- /dev/null
+++ b/dev-libs/libcdio-paranoia/files/libcdio-paranoia-0.90-oos-tests.patch
@@ -0,0 +1,48 @@
+From 4803c621d4f907402f29eba8cc3a6515bdda2ee2 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Mon, 12 Jun 2017 21:20:35 +0100
+Subject: [PATCH] configure.ac: fix out-of-tree tests
+
+To reproduce the test failure one needs to run
+configure using absolute path in a directory
+outside source tree. For example:
+
+ $ $(pwd)/../libcdio-paranoia/configure
+ $ make
+ $ make check
+
+This will cause 'native_abs_top_srcdir' to contain wrong path.
+
+It happens because '[]' is an escape in autoconf.
+As a the following configure.ac snippet:
+ [\\/]* | ?:[\\/]* ) # Absolute name.
+gets translated into the following shell code:
+ \\/* | ?:\\/* ) # Absolute name.
+
+The fix is to change quotes from '[]' for a short while.
+
+Reported-by: eroen
+Reported-by: Paolo Pedroni
+Bug: https://bugs.gentoo.org/546388
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+---
+ configure.ac | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index a502273..608277b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -243,7 +243,9 @@ dnl native_abs_top_srcdir is used here.
+ case $srcdir in
+ .) # We are building in place.
+ native_abs_top_srcdir=$ac_pwd ;;
++ changequote(`,')
+ [\\/]* | ?:[\\/]* ) # Absolute name.
++ changequote([,])
+ native_abs_top_srcdir=$srcdir ;;
+ *) # Relative name.
+ native_abs_top_srcdir=$ac_pwd/$srcdir ;;
+--
+2.13.1
+