summaryrefslogtreecommitdiff
path: root/dev-libs/libbytesize
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /dev-libs/libbytesize
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'dev-libs/libbytesize')
-rw-r--r--dev-libs/libbytesize/Manifest2
-rw-r--r--dev-libs/libbytesize/libbytesize-1.3-r1.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-libs/libbytesize/Manifest b/dev-libs/libbytesize/Manifest
index d20c1491cd3e..b6aa7269d60b 100644
--- a/dev-libs/libbytesize/Manifest
+++ b/dev-libs/libbytesize/Manifest
@@ -1,3 +1,5 @@
DIST libbytesize-1.2.tar.gz 70598 BLAKE2B e136b1274703da7b3596e7583cea1ac773c1594af09c626f4dbb481dfcc23a3186b03ebdc54bba67d0a063c5d6587f6b7f8b610828c461cfd114eea1388dd193 SHA512 a8151e7440d0ec43d10239ddf08a9924827cdf08f20a16dff6177b444c1022fab905a0567384531e7610d854998111adb77f9a6a98e2d9648c02521f84ea2bf2
+DIST libbytesize-1.3.tar.gz 71648 BLAKE2B 40794a38af8ee1fcc03ef8000b20123c0e02e208f329a75e7da3a18b224e4a8456ce5982d72e4eefa2ff9d9dcd90b98142037dd37be6bc31f25e2ff347010829 SHA512 a50f5d4ea07a295909e09168518f8fc25da8dcd52859beca9c9c3b8c8c180b025c774c730d449ffbd4c7fd5aba07b5d071b6d9ad36f9d9ebc96bb06699aa08f3
EBUILD libbytesize-1.2-r1.ebuild 1121 BLAKE2B adeb34d6a094c98baf2cd24976d9f6c43fd5017487204e3a71cadb5f4faf5d5ae6ae86e03d9cb39c96514f82ffe4ed7951907ea6e415412b5d014e2e2b9c2ee2 SHA512 2bf66f52f179def0671d5e82dbcbf060c729e1cb8927ca166df8095b93d1d741096fbecf0012f1e96ba11758e35fb0c63ea8a0eff18a65673f50beab1914b183
+EBUILD libbytesize-1.3-r1.ebuild 1172 BLAKE2B 1259bfd64dc643e2b0be00996498b8a4cee7d855b8440051aed230c4627e2d456b215286f14838fc0aa1198b633cb7e95ead31872f4e3577c30fd01555bd3a03 SHA512 a38faece39e1efff17024a78508537762bd7cbb650a96451c28897be614fcbfa741c0e6eb7d40bc209fb3bc0b1ccabff2f1d9654eb838eb97683eb3b7a77af14
MISC metadata.xml 349 BLAKE2B 3dd4c7645734d29bef7f4224c72284f6bf3583287803ddd3fa94b75f784bb41762d96cd7eb0778f363e9fdbc014b52b93ea86900983553afab993cdba2c68282 SHA512 c54a783eca349652ac007075ff736d1cb53647e702ca8aa12915ae1109e5aee536591afc0b9fe0ac427e41fcf5b86d9d3f47fa5570001c84301c5cba8bca7e9a
diff --git a/dev-libs/libbytesize/libbytesize-1.3-r1.ebuild b/dev-libs/libbytesize/libbytesize-1.3-r1.ebuild
new file mode 100644
index 000000000000..8506a7a74ea1
--- /dev/null
+++ b/dev-libs/libbytesize/libbytesize-1.3-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit autotools python-r1
+
+DESCRIPTION="Tiny library providing a C \"class\" for working with arbitrary big sizes in bytes"
+HOMEPAGE="https://github.com/rhinstaller/libbytesize"
+SRC_URI="https://github.com/rhinstaller/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/gmp:0=
+ dev-libs/mpfr:=
+ >=dev-libs/libpcre-8.32
+"
+
+DEPEND="
+ ${RDEPEND}
+ sys-devel/gettext
+ doc? ( dev-util/gtk-doc )
+ test? (
+ dev-python/pocketlint
+ dev-python/polib
+ )
+"
+
+RESTRICT="test"
+
+pkg_setup() {
+ python_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --without-python3
+ $(use_with doc gtk-doc)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+
+ python_install() {
+ emake -C src/python install DESTDIR="${D}"
+ python_optimize
+ }
+ python_foreach_impl python_install
+
+ find "${ED}" -name "*.la*" -delete || die
+}