summaryrefslogtreecommitdiff
path: root/dev-libs/libbytesize/libbytesize-1.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
commiteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (patch)
treece35c6d01b5ff5de95c3a20fef853b9a6518ad2e /dev-libs/libbytesize/libbytesize-1.3-r1.ebuild
parentb7ebc951da8800f711142f69d9d958bde67a112d (diff)
gentoo resync : 04.05.2019
Diffstat (limited to 'dev-libs/libbytesize/libbytesize-1.3-r1.ebuild')
-rw-r--r--dev-libs/libbytesize/libbytesize-1.3-r1.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/dev-libs/libbytesize/libbytesize-1.3-r1.ebuild b/dev-libs/libbytesize/libbytesize-1.3-r1.ebuild
deleted file mode 100644
index 46301df5958b..000000000000
--- a/dev-libs/libbytesize/libbytesize-1.3-r1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_{5,6}} )
-
-inherit autotools python-r1
-
-DESCRIPTION="Tiny library providing a C \"class\" for working with arbitrary big sizes in bytes"
-HOMEPAGE="https://github.com/rhinstaller/libbytesize"
-SRC_URI="https://github.com/rhinstaller/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="LGPL-2+"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc test"
-
-RDEPEND="
- ${PYTHON_DEPS}
- dev-libs/gmp:0=
- dev-libs/mpfr:=
- >=dev-libs/libpcre-8.32
-"
-
-DEPEND="
- ${RDEPEND}
- sys-devel/gettext
- doc? ( dev-util/gtk-doc )
- test? (
- dev-python/pocketlint
- dev-python/polib
- )
-"
-
-RESTRICT="test"
-
-pkg_setup() {
- python_setup
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --without-python3 #634840
- $(use_with doc gtk-doc)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- emake install DESTDIR="${D}"
-
- python_install() {
- emake -C src/python install DESTDIR="${D}"
- python_optimize
- }
- python_foreach_impl python_install
-
- find "${ED}" -name "*.la*" -delete || die
-}