summaryrefslogtreecommitdiff
path: root/dev-libs/libbulletml/libbulletml-0.0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/libbulletml/libbulletml-0.0.6.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/libbulletml/libbulletml-0.0.6.ebuild')
-rw-r--r--dev-libs/libbulletml/libbulletml-0.0.6.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/libbulletml/libbulletml-0.0.6.ebuild b/dev-libs/libbulletml/libbulletml-0.0.6.ebuild
new file mode 100644
index 000000000000..8a90adf32396
--- /dev/null
+++ b/dev-libs/libbulletml/libbulletml-0.0.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="A Library of Bullet Markup Language"
+HOMEPAGE="http://shinh.skr.jp/libbulletml/index_en.html"
+SRC_URI="http://shinh.skr.jp/libbulletml/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="dev-libs/boost"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${PN#lib}/src
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc46.patch
+ rm -r boost || die
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+}
+
+src_install() {
+ dolib.a libbulletml.a
+
+ insinto /usr/include/bulletml
+ doins *.h
+
+ insinto /usr/include/bulletml/tinyxml
+ doins tinyxml/tinyxml.h
+
+ insinto /usr/include/bulletml/ygg
+ doins ygg/ygg.h
+
+ dodoc ../README*
+}