summaryrefslogtreecommitdiff
path: root/dev-libs/libbsd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /dev-libs/libbsd
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'dev-libs/libbsd')
-rw-r--r--dev-libs/libbsd/Manifest2
-rw-r--r--dev-libs/libbsd/libbsd-0.11.3.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/libbsd/Manifest b/dev-libs/libbsd/Manifest
index 5dc691266d32..002e67a12342 100644
--- a/dev-libs/libbsd/Manifest
+++ b/dev-libs/libbsd/Manifest
@@ -1,3 +1,5 @@
DIST libbsd-0.10.0.tar.xz 393576 BLAKE2B 66005a511dae7fb799322c813b8ea058ab460e3b9044756d6efad5de741d8f70270496f09803bbce8cd0000ff37e998f18e092037c850826c3c8e3f47ddfdb28 SHA512 b75529785b16c93d31401187f8a58258fbebe565dac071c8311775c913af989f62cd29d5ce2651af3ea6221cffd31cf04826577d3e546ab9ca14340f297777b9
+DIST libbsd-0.11.3.tar.xz 399712 BLAKE2B 1af04b8fcbc0bfa59fba549639d61a33ac934fe7ee42b506d1b0452e0b836b0bfdd3d8739de90465be46fe6a9d326a2d11bcf72280aa19ccba81db5da6d63d89 SHA512 a7015ea1ffa3766b1a4690526a25231898ad8275149b31fb6801082450172249997c36165626d101ffce53b59767a46676eebc0806426922fe4e773a0376c1f5
EBUILD libbsd-0.10.0.ebuild 1240 BLAKE2B 8fd9398aff8163c5651bd1ea4edfc1afc6e0a1c0309be8afec21dc719d5259b3931975f713e86e1825af00b2bccfe64b19fa69c7f7958739a0eb966c330ebfd2 SHA512 1ee29cd1a6175d09427a1d56311dad8b341c5094c7a24f8dceaa5e7114941e91ad9dc014153a57009ac79fe5851140def2e9cf0a3a238da654be87fce3640eba
+EBUILD libbsd-0.11.3.ebuild 1271 BLAKE2B 1316524cc5d92f4303183956851709019a73a017dfe7f9368b50dcbcb377d0d2e26c136f19cd118277678f91fbdc657d4e51a2931bcb0f2a0248edad9d8db8b4 SHA512 d1f9d9b6e2eeec540beaa4c89f0c039089cae47a499a38ebbce35cc07aa4c86922cb059519f23155a0d63d7d0bf4bfb8c7e59a22bd448f876feca5e10c25714a
MISC metadata.xml 362 BLAKE2B 5ffa8ebebcf0fd8d01f49f14b8f6a210a45a057669f88343e77a25907af8b4608f24898f7ad8b0367b1fa162de3ea7f6ae1692d7655ef899f72760d9b156cc1d SHA512 6bf19529af2e728fd1bb249f5f15875726ceeeb98f820c618aa8d8b9db8aebef20019e38486c5490e2808af57e4531f54201083514e6d3e20415ed08dd22e3bc
diff --git a/dev-libs/libbsd/libbsd-0.11.3.ebuild b/dev-libs/libbsd/libbsd-0.11.3.ebuild
new file mode 100644
index 000000000000..d9667f872ea7
--- /dev/null
+++ b/dev-libs/libbsd/libbsd-0.11.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+DESCRIPTION="Library to provide useful functions commonly found on BSD systems"
+HOMEPAGE="https://libbsd.freedesktop.org/wiki/ https://gitlab.freedesktop.org/libbsd/libbsd"
+SRC_URI="https://${PN}.freedesktop.org/releases/${P}.tar.xz"
+
+LICENSE="BSD BSD-2 BSD-4 ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND="app-crypt/libmd[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-3.17
+"
+
+pkg_setup() {
+ local f="${EROOT}/usr/$(get_libdir)/${PN}.a"
+ if ! has_version ${CATEGORY}/${PN}; then
+ if [[ -e ${f} ]]; then
+ eerror "${m}"
+ die "You need to remove ${f} by hand or re-emerge sys-libs/glibc first."
+ fi
+ fi
+}
+
+multilib_src_configure() {
+ # The build system will install libbsd-ctor.a despite of USE="-static-libs"
+ # which is correct, see:
+ # https://gitlab.freedesktop.org/libbsd/libbsd/commit/c5b959028734ca2281250c85773d9b5e1d259bc8
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ find "${ED}" -type f -name "*.la" -delete || die
+}