summaryrefslogtreecommitdiff
path: root/dev-libs/libatasmart
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libatasmart
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libatasmart')
-rw-r--r--dev-libs/libatasmart/Manifest5
-rw-r--r--dev-libs/libatasmart/libatasmart-0.19-r1.ebuild41
-rw-r--r--dev-libs/libatasmart/libatasmart-0.19-r2.ebuild41
-rw-r--r--dev-libs/libatasmart/metadata.xml7
4 files changed, 94 insertions, 0 deletions
diff --git a/dev-libs/libatasmart/Manifest b/dev-libs/libatasmart/Manifest
new file mode 100644
index 000000000000..f1d3afa3ab32
--- /dev/null
+++ b/dev-libs/libatasmart/Manifest
@@ -0,0 +1,5 @@
+DIST libatasmart-0.19.tar.xz 251204 BLAKE2B 7e2a9823c27eee5a41f93464b28236239891349639162c5fdc114c241a70fb39a3046c3de16ce402787cd86e13609fff0578bd26f7a2c994fefe3c9756d45968 SHA512 ec9edb019c477873b01289ba365ad0ed0946505d651c1f6f83a63ef61b3976a5db6439c8a0c74d9a55325db9a3a587ad6f655f8d1af9387b0d08356eccabdb62
+DIST libatasmart_0.19-2.debian.tar.gz 6511 BLAKE2B d283dd1db988b95436a99cf804790b6c9b22d48b41d561a6fd2b9aff0948241ab5e775c5c35691692103acd5e73ad2e46278b9d37f886cd48c91cc69353a1564 SHA512 78e86b0c1d2a56dddc8d9ac97ee325871e319ad2226f1fbd5a048d792cd05e5d8162d282c1f767086da5329cd1ee67b37fbb5a2fd3c950f84e9efab11abcf754
+EBUILD libatasmart-0.19-r1.ebuild 947 BLAKE2B 073735d386281eed2d06473756dc5c2320c630f682c5896961fead7384c9b015fe998d18fc10481f3989ad28fcdc34efb0f2d4b6f7dc0da1b18e75debfcb0d98 SHA512 9f01383cfd7db79cfa99d76f9a8b8c6fd2eb91d329c1b99ef32103c107fe731286b6103fa4748e304787ef16ff41e10d16db2b29788966b1854a19e7f6e478b0
+EBUILD libatasmart-0.19-r2.ebuild 963 BLAKE2B bfb008fdbeada89ef36350dec054fbd5d4085153eab95c87cac47fb82579c687a7fa3de8373f58d58977f0c4691e242c16332ea7b888a04448415c3c6b6e19da SHA512 cf2249decbdf24d67df1d55017703607b1d392f1047a19eff6de791bad27397a682aa75b7ce754319fd93a1fbe456696fe613f9ff6f85ceac9d6c94b1206fec3
+MISC metadata.xml 232 BLAKE2B b8ca675b002ba96d45a3afe7b6dd9f0e74d21db87eb002f72bae4e23fd49602115a18b372084596fdc09c3dccef80ae95ab540dad93fdf5dab0c9fb34f5d28db SHA512 21ba416ac701f1c9deb55d07f8afbf9da930fb04d274d84c5cf0df5e549554059959228ee6a4b8523d985fe0762af1a7c36aaefcb0e5b3c7baa5866e2841cfb4
diff --git a/dev-libs/libatasmart/libatasmart-0.19-r1.ebuild b/dev-libs/libatasmart/libatasmart-0.19-r1.ebuild
new file mode 100644
index 000000000000..f2820bf64e2b
--- /dev/null
+++ b/dev-libs/libatasmart/libatasmart-0.19-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils
+
+PATCH_LEVEL=2
+
+DESCRIPTION="A small and lightweight parser library for ATA S.M.A.R.T. hard disks"
+HOMEPAGE="http://0pointer.de/blog/projects/being-smart.html"
+SRC_URI="http://0pointer.de/public/${P}.tar.xz
+ mirror://debian/pool/main/liba/${PN}/${PN}_${PV}-${PATCH_LEVEL}.debian.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86"
+IUSE="static-libs"
+
+RDEPEND="virtual/udev"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="README"
+
+src_prepare() {
+ # https://bugs.gentoo.org/470874
+ local d="${WORKDIR}"/debian/patches
+ sed -i -e '/#/d' "${d}"/series || die
+ EPATCH_SOURCE="${d}" epatch $(<"${d}"/series)
+}
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/dev-libs/libatasmart/libatasmart-0.19-r2.ebuild b/dev-libs/libatasmart/libatasmart-0.19-r2.ebuild
new file mode 100644
index 000000000000..2117666652ca
--- /dev/null
+++ b/dev-libs/libatasmart/libatasmart-0.19-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+PATCH_LEVEL=2
+
+DESCRIPTION="A small and lightweight parser library for ATA S.M.A.R.T. hard disks"
+HOMEPAGE="http://0pointer.de/blog/projects/being-smart.html"
+SRC_URI="http://0pointer.de/public/${P}.tar.xz
+ mirror://debian/pool/main/liba/${PN}/${PN}_${PV}-${PATCH_LEVEL}.debian.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/4"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86"
+IUSE="static-libs"
+
+RDEPEND="virtual/libudev:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # https://bugs.gentoo.org/470874
+ local d="${WORKDIR}"/debian/patches
+ sed -i -e '/#/d' \
+ -e "s|^|${d}/|" "${d}"/series || die
+ eapply $(<"${d}"/series)
+ eapply_user
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/dev-libs/libatasmart/metadata.xml b/dev-libs/libatasmart/metadata.xml
new file mode 100644
index 000000000000..f3cab85cf603
--- /dev/null
+++ b/dev-libs/libatasmart/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>freedesktop-bugs@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>