summaryrefslogtreecommitdiff
path: root/dev-libs/libatasmart
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /dev-libs/libatasmart
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'dev-libs/libatasmart')
-rw-r--r--dev-libs/libatasmart/Manifest2
-rw-r--r--dev-libs/libatasmart/libatasmart-0.19_p5.ebuild19
2 files changed, 16 insertions, 5 deletions
diff --git a/dev-libs/libatasmart/Manifest b/dev-libs/libatasmart/Manifest
index bf59a61449f7..debf14c3dc23 100644
--- a/dev-libs/libatasmart/Manifest
+++ b/dev-libs/libatasmart/Manifest
@@ -1,4 +1,4 @@
DIST libatasmart_0.19-5.debian.tar.xz 6452 BLAKE2B 09bde3d5d79062d4df82e5582e932b6b566a91607086ddd805925d1966cdee4cb4ba43863f4b7d26a98588479b117841050f762d23c6719448635bf1e681b315 SHA512 434b6ef3ea377485ce745e147da8bb72851b2eeabe6f418379511650f0161f15a9ee21f4f0b5f9beb218b99eb417c1aeafdea4640995efbaf45024f40ce71802
DIST libatasmart_0.19.orig.tar.xz 251204 BLAKE2B 7e2a9823c27eee5a41f93464b28236239891349639162c5fdc114c241a70fb39a3046c3de16ce402787cd86e13609fff0578bd26f7a2c994fefe3c9756d45968 SHA512 ec9edb019c477873b01289ba365ad0ed0946505d651c1f6f83a63ef61b3976a5db6439c8a0c74d9a55325db9a3a587ad6f655f8d1af9387b0d08356eccabdb62
-EBUILD libatasmart-0.19_p5.ebuild 953 BLAKE2B c300baedbe81f505db4bf8d939e5878eb2abf7744891cefe00eee99786acd96e2d4347f91ab70e8d349fcf48327c84e62082143e3af4437349cb9f81115100c2 SHA512 9aefdcb54b72a432dbdda6a7791d867d9eca53045e02f4ca9e9fd0aac00d098dee563602c596df95839f13724113a54c2739d63164fad92126fd7e47f131b07d
+EBUILD libatasmart-0.19_p5.ebuild 1182 BLAKE2B 87b7f98e145901e4667953ec4adc4f532cf8f99688a8bb1697fb0262d9d54ea8b7adfdcf9ac8f5d6274df6aeec8d760dd1d51c138aa049f98c507edf3e88cbd1 SHA512 9d758a3bc2924a2eef5362082f38f4cfa76a16280536bae63d5ef50b374d2a56274d03652d74c4c034e77c0b06b5be88b63215f4d3802c756316113f616bb94a
MISC metadata.xml 232 BLAKE2B b8ca675b002ba96d45a3afe7b6dd9f0e74d21db87eb002f72bae4e23fd49602115a18b372084596fdc09c3dccef80ae95ab540dad93fdf5dab0c9fb34f5d28db SHA512 21ba416ac701f1c9deb55d07f8afbf9da930fb04d274d84c5cf0df5e549554059959228ee6a4b8523d985fe0762af1a7c36aaefcb0e5b3c7baa5866e2841cfb4
diff --git a/dev-libs/libatasmart/libatasmart-0.19_p5.ebuild b/dev-libs/libatasmart/libatasmart-0.19_p5.ebuild
index 7da99e26ec24..ca77a0f760aa 100644
--- a/dev-libs/libatasmart/libatasmart-0.19_p5.ebuild
+++ b/dev-libs/libatasmart/libatasmart-0.19_p5.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="A small and lightweight parser library for ATA S.M.A.R.T. hard disks"
HOMEPAGE="https://salsa.debian.org/utopia-team/libatasmart"
SRC_URI="mirror://debian/pool/main/liba/${PN}/${PN}_${PV/_p*}.orig.tar.xz
@@ -10,14 +12,12 @@ SRC_URI="mirror://debian/pool/main/liba/${PN}/${PN}_${PV/_p*}.orig.tar.xz
LICENSE="LGPL-2.1"
SLOT="0/4"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86"
IUSE="static-libs"
RDEPEND="virtual/libudev:="
DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
-"
+BDEPEND="virtual/pkgconfig"
S="${WORKDIR}/${P/_p*}"
@@ -34,6 +34,17 @@ src_configure() {
econf $(use_enable static-libs static)
}
+src_compile() {
+ if tc-is-cross-compiler; then
+ tc-export_build_env
+ emake -C strpool strpool \
+ CFLAGS="${BUILD_CFLAGS}" \
+ CPPFLAGS="${BUILD_CPPFLAGS}" \
+ LDFLAGS="${BUILD_LDFLAGS}"
+ fi
+ emake
+}
+
src_install() {
default
find "${ED}" -type f -name "*.la" -delete || die