summaryrefslogtreecommitdiff
path: root/dev-libs/libansilove/libansilove-1.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-libs/libansilove/libansilove-1.3.0.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-libs/libansilove/libansilove-1.3.0.ebuild')
-rw-r--r--dev-libs/libansilove/libansilove-1.3.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-libs/libansilove/libansilove-1.3.0.ebuild b/dev-libs/libansilove/libansilove-1.3.0.ebuild
new file mode 100644
index 000000000000..e0470e9d552a
--- /dev/null
+++ b/dev-libs/libansilove/libansilove-1.3.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="library to convert ANSi and artscene related file formats into PNG images"
+HOMEPAGE="https://github.com/ansilove/libansilove"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ansilove/${PN}.git"
+else
+ SRC_URI="https://github.com/ansilove/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="media-libs/gd:2=[png]"
+DEPEND="${RDEPEND}"