summaryrefslogtreecommitdiff
path: root/dev-libs/kreport
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-libs/kreport
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-libs/kreport')
-rw-r--r--dev-libs/kreport/Manifest2
-rw-r--r--dev-libs/kreport/files/kreport-3.2.0-gcc10.patch120
-rw-r--r--dev-libs/kreport/kreport-3.2.0-r1.ebuild58
3 files changed, 180 insertions, 0 deletions
diff --git a/dev-libs/kreport/Manifest b/dev-libs/kreport/Manifest
index 687421953941..f3934e9bc26b 100644
--- a/dev-libs/kreport/Manifest
+++ b/dev-libs/kreport/Manifest
@@ -1,3 +1,5 @@
+AUX kreport-3.2.0-gcc10.patch 4160 BLAKE2B 1d3e579ac1c2e6da0cecc22a2128746a6f3fdf99c7b4b5b66e0992f10ec9555b83efc6b6eff62acc5c2a72299abf3baf6b0e7fec9b7b0c57702a23d7cdc4cec4 SHA512 a378710adb3c885591dadb878ad6c4c8ed6c3e92feebfd59aaf8eaf1f03ddbe720d4480622e744c37ec0d7bb52812b9e91eef90ff5d3af30f70da7bbbba5aff8
DIST kreport-3.2.0.tar.xz 374072 BLAKE2B b0e4a028464f424e1e6661a02233a0e6f711a890892ea34c8c8ebc12675379a233e9aa8b00f9165e9a82993d43ae2086c7a8c0f5cc17cfaa658614225c7b56c8 SHA512 3f7b8bf8d4c5e88de74b38c55b4c82ac1e3ae11db424b10b85884ff479d25640b0ef7c6f90567cf27a1bab099d4b14a042ddf4549cec9ca7d5b237c3a8f7104c
+EBUILD kreport-3.2.0-r1.ebuild 1379 BLAKE2B 29e9eb5d8bb5f72bb6beb7fd3ffae37bedbf1153a207d4c661201d40a62233a30c4d99967fc8441c8bedfdc3382b83d3a4a3b4cdaca63dc7bfa218b763f65dcb SHA512 f13c2b26d270addcb8644ab542471746590d06d44be6fc540e70605fa66e67904ca1b4d6547501a8f66e86358d231b5d94e09649193bdbc2494c0d012caca4fb
EBUILD kreport-3.2.0.ebuild 1343 BLAKE2B 00a2a331bee70beca3e04b3cc8b55c91f5e4bef86220e0b7bfbaffdb0453a3476c427d6434bc111641997c93acca918c5842aa443f6657b01613a21712c8af9c SHA512 c885b487aba1ba67d553917e9f6b74ca0afbab5a760200abd07c2efa488be5cbca6610cc51f2bdd517b791cd8b014d58ad624895c775f08196d02471946c8ef0
MISC metadata.xml 444 BLAKE2B 6bcc5b1d127a801fae72db2855c9b01ffeef4d118554164d8d7c02e3edd7d0f00e22f3f6dbf45cdbe1b8c764d6efdbd3034ffc6b8cf041b7e9537d59a6629740 SHA512 7356b187c34c57ab44573e7cd3da164888c2b261c2faecc8f890db1eedae63573587447f44356dba9ee2d6218034e13cb093dbed4f63589a6f0544123f7680b9
diff --git a/dev-libs/kreport/files/kreport-3.2.0-gcc10.patch b/dev-libs/kreport/files/kreport-3.2.0-gcc10.patch
new file mode 100644
index 000000000000..8d5b26bee064
--- /dev/null
+++ b/dev-libs/kreport/files/kreport-3.2.0-gcc10.patch
@@ -0,0 +1,120 @@
+From 5d3053ea78b349b81b7a562974ad78f93d169791 Mon Sep 17 00:00:00 2001
+From: Jaroslaw Staniek <staniek@kde.org>
+Date: Tue, 16 Jun 2020 21:59:12 +0200
+Subject: [PATCH] Fix build with GCC 10 (make KReportGroupTracker use C++ file)
+
+BUG:422886
+CCMAIL:adam@piggz.co.uk
+
+FIXED-IN:3.2.1
+---
+ src/CMakeLists.txt | 5 +---
+ .../scripting/KReportGroupTracker.cpp | 26 +++++++++++++++++++
+ src/renderer/scripting/KReportGroupTracker.h | 25 +++++++++++++++---
+ 3 files changed, 48 insertions(+), 8 deletions(-)
+ create mode 100644 src/renderer/scripting/KReportGroupTracker.cpp
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 1cf0b389..65bcf6e5 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -106,6 +106,7 @@ set(kreport_TARGET_INCLUDE_DIRS
+
+ if(KREPORT_SCRIPTING)
+ list(APPEND kreport_LIB_SRCS
++ renderer/scripting/KReportGroupTracker.cpp
+ renderer/scripting/KReportScriptHandler.cpp
+ renderer/scripting/KReportScriptConstants.cpp
+ renderer/scripting/KReportScriptDebug.cpp
+@@ -133,10 +134,6 @@ if(KREPORT_SCRIPTING)
+ items/text/KReportScriptText.cpp
+ )
+
+- qt_wrap_cpp(KReport kreport_LIB_SRCS
+- renderer/scripting/KReportGroupTracker.h
+- )
+-
+ list(APPEND kreport_INCLUDE_DIRS
+ ${CMAKE_CURRENT_SOURCE_DIR}/renderer/scripting
+ )
+diff --git a/src/renderer/scripting/KReportGroupTracker.cpp b/src/renderer/scripting/KReportGroupTracker.cpp
+new file mode 100644
+index 00000000..9274d4a5
+--- /dev/null
++++ b/src/renderer/scripting/KReportGroupTracker.cpp
+@@ -0,0 +1,26 @@
++/* This file is part of the KDE project
++ * Copyright (C) 2015 by Adam Pigg (adam@piggz.co.uk)
++ *
++ * This library is free software; you can redistribute it and/or
++ * modify it under the terms of the GNU Lesser General Public
++ * License as published by the Free Software Foundation; either
++ * version 2.1 of the License, or (at your option) any later version.
++ *
++ * This library is distributed in the hope that it will be useful,
++ * but WITHOUT ANY WARRANTY; without even the implied warranty of
++ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
++ * Lesser General Public License for more details.
++ *
++ * You should have received a copy of the GNU Lesser General Public
++ * License along with this library. If not, see <http://www.gnu.org/licenses/>.
++ */
++
++#include "KReportGroupTracker.h"
++
++KReportGroupTracker::KReportGroupTracker()
++{
++}
++
++KReportGroupTracker::~KReportGroupTracker()
++{
++}
+diff --git a/src/renderer/scripting/KReportGroupTracker.h b/src/renderer/scripting/KReportGroupTracker.h
+index e434e05a..4c0852ea 100644
+--- a/src/renderer/scripting/KReportGroupTracker.h
++++ b/src/renderer/scripting/KReportGroupTracker.h
+@@ -1,3 +1,20 @@
++/* This file is part of the KDE project
++ * Copyright (C) 2015 by Adam Pigg (adam@piggz.co.uk)
++ *
++ * This library is free software; you can redistribute it and/or
++ * modify it under the terms of the GNU Lesser General Public
++ * License as published by the Free Software Foundation; either
++ * version 2.1 of the License, or (at your option) any later version.
++ *
++ * This library is distributed in the hope that it will be useful,
++ * but WITHOUT ANY WARRANTY; without even the implied warranty of
++ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
++ * Lesser General Public License for more details.
++ *
++ * You should have received a copy of the GNU Lesser General Public
++ * License along with this library. If not, see <http://www.gnu.org/licenses/>.
++ */
++
+ #ifndef KREPORTGROUPTRACKER_H
+ #define KREPORTGROUPTRACKER_H
+
+@@ -7,16 +24,16 @@
+ /*!
+ * @brief Keeps track of groups as the data for the group changes
+ */
+-class KREPORT_EXPORT KReportGroupTracker : public QObject {
++class KREPORT_EXPORT KReportGroupTracker : public QObject
++{
+ Q_OBJECT
+
+ protected:
+- KReportGroupTracker() {}
+- ~KReportGroupTracker() override{}
++ KReportGroupTracker();
++ ~KReportGroupTracker() override;
+
+ public:
+ Q_SLOT virtual void setGroupData(const QMap<QString, QVariant> &groupData) = 0;
+ };
+
+ #endif // KREPORTGROUPTRACKER_H
+-
+--
+GitLab
+
diff --git a/dev-libs/kreport/kreport-3.2.0-r1.ebuild b/dev-libs/kreport/kreport-3.2.0-r1.ebuild
new file mode 100644
index 000000000000..058f6a40c5ba
--- /dev/null
+++ b/dev-libs/kreport/kreport-3.2.0-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="true"
+ECM_TEST="true"
+PYTHON_COMPAT=( python3_{7,8,9} )
+KFMIN=5.74.0
+QTMIN=5.15.1
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org python-any-r1
+
+DESCRIPTION="Framework for creation and generation of reports in multiple formats"
+HOMEPAGE="https://community.kde.org/KReport"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-2+"
+SLOT="5/4"
+IUSE="marble +scripting webkit"
+
+RDEPEND="
+ >=dev-libs/kproperty-${PV}:5=
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ marble? ( kde-apps/marble:5= )
+ scripting? ( >=dev-qt/qtdeclarative-${QTMIN}:5 )
+ webkit? ( >=dev-qt/qtwebkit-5.212.0_pre20180120:5 )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+"
+
+PATCHES=( "${FILESDIR}/${P}-gcc10.patch" )
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ ecm_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package marble Marble)
+ $(cmake_use_find_package webkit Qt5WebKitWidgets)
+ -DKREPORT_SCRIPTING=$(usex scripting)
+ )
+ ecm_src_configure
+}