summaryrefslogtreecommitdiff
path: root/dev-libs/kqoauth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/kqoauth
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/kqoauth')
-rw-r--r--dev-libs/kqoauth/Manifest3
-rw-r--r--dev-libs/kqoauth/kqoauth-0.98-r2.ebuild46
-rw-r--r--dev-libs/kqoauth/metadata.xml15
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-libs/kqoauth/Manifest b/dev-libs/kqoauth/Manifest
new file mode 100644
index 000000000000..ed26f9675844
--- /dev/null
+++ b/dev-libs/kqoauth/Manifest
@@ -0,0 +1,3 @@
+DIST kqoauth-0.98.tar.gz 37059 BLAKE2B d1214ac22cb52e7ead1be3ce7af2af9c4b2e1cb74e2b4bf3891300099c0a0abb0c7295fb4616adcb59cb4405eb52bec4097b48d39563ac407bfe692ce94492a2 SHA512 f89e0f046fb7fd7812548f94c460d7c18d4881972e155a99e07503e97fd46b6eada0de9f2c3a94af33ef5b1b3b489bbd5dc6738cee104fe2d11ed62e681c7979
+EBUILD kqoauth-0.98-r2.ebuild 980 BLAKE2B 4ae4037f10861ebe48c087b7d1f67179123b49dea9833aba9d47842c8845714a1481822a0b9f2a5da14a6ba668b69e70f426101ef491cd6ae3716da10d1a75d2 SHA512 e21769ccb5b3c837a57421ead31d67cbb9890aadda59544254ed08f3647b7fab53d8f7ff635706a8d43d1485a3f19813b3cd7275c904f618061dafcc66b4a5bc
+MISC metadata.xml 443 BLAKE2B e38dcf6daed9ac5a23061075de0f992b2e3a879ca35450617ce70dc3a007ea989ffce209a4ac150a98cfe37c6bd013484a3dca219934479128ad11bc493a7b93 SHA512 56182d7d36d0d01d2a64393e60cefb440650b46dbc45e102cfa7f3fe6431552dd4dfa03eb4f34a284fb8dfafa14ef711fb8586a7beaf6aed71f6048401c89aaf
diff --git a/dev-libs/kqoauth/kqoauth-0.98-r2.ebuild b/dev-libs/kqoauth/kqoauth-0.98-r2.ebuild
new file mode 100644
index 000000000000..dbfc65327cd6
--- /dev/null
+++ b/dev-libs/kqoauth/kqoauth-0.98-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="Library for Qt that implements the OAuth 1.0 authentication specification"
+HOMEPAGE="https://github.com/kypeli/kQOAuth"
+SRC_URI="https://github.com/kypeli/kQOAuth/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtxml:5
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/kQOAuth-${PV}"
+
+src_prepare() {
+ default
+
+ # prevent tests from beeing built at src_compile
+ sed -i -e '/SUBDIRS/s/ tests//' ${PN}.pro || die "sed on ${PN}.pro failed"
+ # respect libdir
+ sed -e 's:{INSTALL_PREFIX}/lib:[QT_INSTALL_LIBS]:g' -i src/src.pro || die "sed on src.pro failed"
+
+ sed \
+ -e "s/TARGET = kqoauth/TARGET = kqoauth-qt5/g" \
+ -i src/src.pro || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
diff --git a/dev-libs/kqoauth/metadata.xml b/dev-libs/kqoauth/metadata.xml
new file mode 100644
index 000000000000..47acb0dadc7b
--- /dev/null
+++ b/dev-libs/kqoauth/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>0xd34df00d@gmail.com</email>
+ <name>Georg Rudoy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">kypeli/kQOAuth</remote-id>
+ </upstream>
+</pkgmetadata>