summaryrefslogtreecommitdiff
path: root/dev-libs/jsoncpp/jsoncpp-1.9.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /dev-libs/jsoncpp/jsoncpp-1.9.4.ebuild
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'dev-libs/jsoncpp/jsoncpp-1.9.4.ebuild')
-rw-r--r--dev-libs/jsoncpp/jsoncpp-1.9.4.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-libs/jsoncpp/jsoncpp-1.9.4.ebuild b/dev-libs/jsoncpp/jsoncpp-1.9.4.ebuild
deleted file mode 100644
index 5c858b99e519..000000000000
--- a/dev-libs/jsoncpp/jsoncpp-1.9.4.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit meson python-any-r1
-
-DESCRIPTION="C++ JSON reader and writer"
-HOMEPAGE="https://github.com/open-source-parsers/jsoncpp"
-SRC_URI="
- https://github.com/open-source-parsers/${PN}/archive/${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="|| ( public-domain MIT )"
-SLOT="0/24"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- ${PYTHON_DEPS}
- doc? ( app-doc/doxygen )"
-RDEPEND=""
-
-src_configure() {
- local emesonargs=(
- # Follow Debian, Ubuntu, Arch convention for headers location
- # bug #452234
- --includedir include/jsoncpp
- -Dtests=$(usex test true false)
- )
- meson_src_configure
-}
-
-src_compile() {
- meson_src_compile
-
- if use doc; then
- echo "${PV}" > version || die
- "${EPYTHON}" doxybuild.py --doxygen="${EPREFIX}"/usr/bin/doxygen || die
- HTML_DOCS=( dist/doxygen/jsoncpp*/. )
- fi
-}
-
-src_test() {
- # increase test timeout due to failures on slower hardware
- meson_src_test -t 2
-}