summaryrefslogtreecommitdiff
path: root/dev-libs/json-glib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/json-glib
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/json-glib')
-rw-r--r--dev-libs/json-glib/Manifest5
-rw-r--r--dev-libs/json-glib/json-glib-1.2.8.ebuild55
-rw-r--r--dev-libs/json-glib/metadata.xml15
3 files changed, 75 insertions, 0 deletions
diff --git a/dev-libs/json-glib/Manifest b/dev-libs/json-glib/Manifest
new file mode 100644
index 000000000000..ddf435499b7d
--- /dev/null
+++ b/dev-libs/json-glib/Manifest
@@ -0,0 +1,5 @@
+DIST json-glib-1.2.8.tar.xz 604336 SHA256 fd55a9037d39e7a10f0db64309f5f0265fa32ec962bf85066087b83a2807f40a SHA512 85d8ad431363b8698d71684927b8aa38749d99ea7236334ec09fd81482489f1ab9cb12dabcbe13f6b6ffd7e5d70ade47a36b511e275915d4aa858af647db90ba WHIRLPOOL 2c770d113e4b1911fe98ca127110c45443a5e992d442265c8e48a65f66d1429bff1099b4015f93d110b547734f4478febe1d27a81e7774cf3f23e0696c51fe18
+EBUILD json-glib-1.2.8.ebuild 1412 SHA256 988eaa1ee15fb119cd292f6a1129b1b44adcde045b650eb348e967a02fed175a SHA512 bef69e80ebe43f4e84d6e1a0a0da1285dbb2538d680bbe9c27e4b780ecbf99a9454309cd1c244ccf3736ac7f82ddf6e69c2bd1b27a1b590b8db7d31e71e2614a WHIRLPOOL 6f311eef8e3dfa21178a3995b46c076a6906ae52f4fdfa164bcd60afdfb1e599751c27bf105cbf529d34a4449907a9b4e3e18cec84d1268b7b69630f29ceac69
+MISC ChangeLog 5632 SHA256 c472f5fe8d6885a014a34705eb446af8afeb63e2de8b3e6c99966c78c8e73679 SHA512 fc22f45afdb591e6c606e6ca729375a7e0d65b4b909fe7cf3ddc87a8ab6902178b3575361dc127b4dc56544db464c0c8d3e1b5f34ca0af676ef700613e0adb9b WHIRLPOOL 662b2662f553f54d4ae872a3b12c82acb97d5b961536445a48044b7a3ea094d3f0b2f541159b787af36120d380251964c4906a3fc0eb6c0c26c97be1ffd8783e
+MISC ChangeLog-2015 11745 SHA256 c22f16b5463b90ec1f89a0183e695f94f5e448f27983d0ba0b5d4b241b838de8 SHA512 344f6bf29b89549343eaab641306abcffe657556be7a42035a89510ff40edc7fd2092a18160632c498b9ed59bcb850487561db30b1fb74ed41bc98a6fa25f68c WHIRLPOOL f9597f09384556d3d5c49d197f74191de1dfebbba38d83a14def930b67a3b16c99bd58d21589b51bf57a4f413441324092f49e38f66e864ad8e0b955f282cd61
+MISC metadata.xml 1168 SHA256 22fe5e8c0646d110145f4f8859ee26030031ffa62d0f6fdb4169f39eb3e3ce16 SHA512 9af9dffd8e1d56c9dad5a0c53bdf16f5d54261c8c121cbc9644865340b84101a0bfcafc393bfe0d6b31024b16f1bbe9f9305286bc56a2df20a08984f55cb91e1 WHIRLPOOL 6181a5b0ae2d57c41f6ba06d7618a2b727995dfe48827b2d78af2b9a2b6eb4eda4e7245d0d8b0478eeddad0c5e8f0399f7524b4eea1681b55f2ab185cc33f90f
diff --git a/dev-libs/json-glib/json-glib-1.2.8.ebuild b/dev-libs/json-glib/json-glib-1.2.8.ebuild
new file mode 100644
index 000000000000..2181414d8a04
--- /dev/null
+++ b/dev-libs/json-glib/json-glib-1.2.8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="Library providing GLib serialization and deserialization for the JSON format"
+HOMEPAGE="https://wiki.gnome.org/Projects/JsonGlib"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="debug +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.37.6:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+"
+DEPEND="${RDEPEND}
+ ~app-text/docbook-xml-dtd-4.1.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.20
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+"
+
+src_prepare() {
+ # Do not touch CFLAGS with --enable-debug=yes
+ sed -e 's/CFLAGS -g/CFLAGS/' -i "${S}"/configure || die
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ # Coverage support is useless, and causes runtime problems
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ --enable-man \
+ --disable-gcov \
+ $(usex debug --enable-debug=yes --enable-debug=minimum) \
+ $(multilib_native_use_enable introspection) \
+ --with-xml-catalog="${EPREFIX}"/etc/xml/catalog
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/doc/html doc/html || die
+ fi
+}
+
+multilib_src_compile() {
+ gnome2_src_compile
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
diff --git a/dev-libs/json-glib/metadata.xml b/dev-libs/json-glib/metadata.xml
new file mode 100644
index 000000000000..0aa1782a946f
--- /dev/null
+++ b/dev-libs/json-glib/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>voyageur@gentoo.org</email>
+ <name>Bernard Cafarelli</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <longdescription>JSON-GLib is a library providing serialization and deserialization support for the JavaScript Object Notation (JSON) format described by RFC 4627. Many high-level languages already provide native modules for parsing, generating and manipulating JSON data streams. JSON-GLib is a C library based on GLib and released under the terms of the GNU Lesser General Public License version 2.1. It provides a parser and a generator GObject classes and various wrappers for the complex data types employed by JSON, such as arrays and objects.
+
+JSON-GLib uses GLib native data types and the generic value container GValue for ease of development. It also provides integration with the GObject classes for direct serialization into, and deserialization from, JSON data streams.</longdescription>
+</pkgmetadata>