summaryrefslogtreecommitdiff
path: root/dev-libs/isa-l_crypto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-24 03:01:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-24 03:01:18 +0100
commita5d03e5440b3955446fba6d02de9f53ea4f6efc4 (patch)
treec1ef5c34e37665a48d85a29c5feadadb9622d627 /dev-libs/isa-l_crypto
parent456fc832c996a122c45240beb68820ab3c2ada40 (diff)
gentoo auto-resync : 24:05:2023 - 03:01:18
Diffstat (limited to 'dev-libs/isa-l_crypto')
-rw-r--r--dev-libs/isa-l_crypto/Manifest4
-rw-r--r--dev-libs/isa-l_crypto/files/isa-l_crypto-2.24.0_makefile-no-D.patch13
-rw-r--r--dev-libs/isa-l_crypto/isa-l_crypto-2.24.0.ebuild43
-rw-r--r--dev-libs/isa-l_crypto/metadata.xml21
4 files changed, 81 insertions, 0 deletions
diff --git a/dev-libs/isa-l_crypto/Manifest b/dev-libs/isa-l_crypto/Manifest
new file mode 100644
index 000000000000..a77131984e47
--- /dev/null
+++ b/dev-libs/isa-l_crypto/Manifest
@@ -0,0 +1,4 @@
+AUX isa-l_crypto-2.24.0_makefile-no-D.patch 476 BLAKE2B 33203776092c6d8d6d2f0e43492d2b5deb85d5ee1a90fbcec410af04d8764a0bd607783fa2c40527ca321daa238ec4ea9b3193526884ea8c14581d417f6f561d SHA512 0ac8610e7a5604250647e3680ac6eddabb24f006167f42bfa0031ae90e8cca007362fc791d0131e5209e6124dda4b4e7f0d73e754c546235f0b8c1db914b1214
+DIST isa-l_crypto-2.24.0.tar.gz 687392 BLAKE2B 10b5e820f9e9d25f0f013d4cfe832760363bf1f1f2759a94f733b25ebd62b52a98262969e24be1ba86d132ee6eaefc9e64c99cceb4f9ba206c848b9aeb45f9d8 SHA512 f72800a8ff9c0b2bfdd88cb6780db91bfd5763af04a6318aa3acaff0b1326e3348cb3a4aff17c99636eb291d1ff6249dcf896392a2450adacd83ddbf4c7299da
+EBUILD isa-l_crypto-2.24.0.ebuild 941 BLAKE2B 8e542219e75ca303650c4dd0f9e95237ce7a67b1f91ee497904bf375bb411b4d265ca7709385820faa4cedb62bd8bf56be163a08382327d9b02f4117cb86c145 SHA512 77a3c2bbbc62a8d8fd3a22a4a303cd0b172d94a5aa5fe80b0abb396f0c838c4c4991f248929861902225ab20f69a0140d7988eefc5af14710e53110f4c3c2534
+MISC metadata.xml 894 BLAKE2B 5b1bc7803ac91b9da3a4f6c200706755f718d0e262bfe9841ec895363e9cfdcd87d3c7f6ff4bfc82d69f7834a4876156f57029d09a6622f61b483eb5c4f2a896 SHA512 a96392b43ad83785eee5afca6917adf6422f07f0ba04f64c921c69d03b3c60f0fd4af54e0675903f8fbb088c281bf6b611393c97bfb1d1bbed6ef0c55a2b6122
diff --git a/dev-libs/isa-l_crypto/files/isa-l_crypto-2.24.0_makefile-no-D.patch b/dev-libs/isa-l_crypto/files/isa-l_crypto-2.24.0_makefile-no-D.patch
new file mode 100644
index 000000000000..dec1420e4d31
--- /dev/null
+++ b/dev-libs/isa-l_crypto/files/isa-l_crypto-2.24.0_makefile-no-D.patch
@@ -0,0 +1,13 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -136,8 +136,8 @@
+ EXTRA_DIST += tools/yasm-filter.sh tools/nasm-filter.sh
+ EXTRA_DIST += tools/yasm-cet-filter.sh tools/nasm-cet-filter.sh
+
+-AM_CFLAGS = ${my_CFLAGS} ${INCLUDE} $(src_include) ${D}
+-AM_CCASFLAGS = ${yasm_args} ${INCLUDE} $(src_include) ${DEFS} ${D}
++AM_CFLAGS = ${my_CFLAGS} ${INCLUDE} $(src_include) ${DIST_D}
++AM_CCASFLAGS = ${yasm_args} ${INCLUDE} $(src_include) ${DEFS} ${DIST_D}
+
+ .asm.s:
+ @echo " MKTMP " $@;
diff --git a/dev-libs/isa-l_crypto/isa-l_crypto-2.24.0.ebuild b/dev-libs/isa-l_crypto/isa-l_crypto-2.24.0.ebuild
new file mode 100644
index 000000000000..5ea355130d4b
--- /dev/null
+++ b/dev-libs/isa-l_crypto/isa-l_crypto-2.24.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Intelligent Storage Acceleration Library - cryptographic components"
+HOMEPAGE="https://github.com/intel/isa-l_crypto"
+SRC_URI="https://github.com/intel/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="cpu_flags_x86_avx512f"
+
+# AVX512 support in yasm is still work in progress
+BDEPEND="amd64? (
+ cpu_flags_x86_avx512f? ( >=dev-lang/nasm-2.13 )
+ !cpu_flags_x86_avx512f? ( || (
+ >=dev-lang/nasm-2.11.01
+ >=dev-lang/yasm-1.2.0
+ ) )
+)"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.24.0_makefile-no-D.patch
+)
+
+src_prepare() {
+ default
+
+ # isa-l does not support arbitrary assemblers on amd64 (and presumably x86),
+ # it must be either nasm or yasm.
+ use amd64 && unset AS
+
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/dev-libs/isa-l_crypto/metadata.xml b/dev-libs/isa-l_crypto/metadata.xml
new file mode 100644
index 000000000000..aed47168584f
--- /dev/null
+++ b/dev-libs/isa-l_crypto/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <longdescription>
+ ISA-L_crypto is a collection of optimized low-level functions targeting storage applications. ISA-L_crypto includes:
+ * Multi-buffer hashes - run multiple hash jobs together on one core for much better throughput than single-buffer versions.
+ * SHA1, SHA256, SHA512, MD5, SM3
+ * Multi-hash - Get the performance of multi-buffer hashing with a single-buffer interface.
+ * Multi-hash + murmur - run both together.
+ * AES - block ciphers
+ * XTS, GCM, CBC
+ * Rolling hash - Hash input in a window which moves through the input
+ </longdescription>
+ <upstream>
+ <remote-id type="github">intel/isa-l_crypto</remote-id>
+ </upstream>
+</pkgmetadata>