summaryrefslogtreecommitdiff
path: root/dev-libs/isa-l
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-libs/isa-l
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-libs/isa-l')
-rw-r--r--dev-libs/isa-l/Manifest4
-rw-r--r--dev-libs/isa-l/files/isa-l-2.30.0_makefile-no-D.patch16
-rw-r--r--dev-libs/isa-l/isa-l-2.30.0-r1.ebuild43
-rw-r--r--dev-libs/isa-l/metadata.xml21
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-libs/isa-l/Manifest b/dev-libs/isa-l/Manifest
new file mode 100644
index 000000000000..7e29b439b147
--- /dev/null
+++ b/dev-libs/isa-l/Manifest
@@ -0,0 +1,4 @@
+AUX isa-l-2.30.0_makefile-no-D.patch 511 BLAKE2B 64e65daf876cde7a5ca4ba8f8f4e308d9a24eb07449e5728250bf88871ea01b62384c74d92f77ca8ea8c47909a389e9add2741ee053ad7be4d0dbf423e2b965c SHA512 5465bf937401a15bf2e3ed8274d1f2ae45428c29739e835d71474d81bfae78b83cd38c762bcbb25fbe62853c979bdfd5e56bce4f0cd43a949c2b61141feb7415
+DIST isa-l-2.30.0.tar.gz 649389 BLAKE2B 3364733d61ce16c91891b6da63d2b4fb2bc004761c91f2076a9a6441adaea24af43b6d32caec011c06206e3811e8c9639f8ceaac89fe97800144c7f78c80c350 SHA512 d3ecfb7326097534b06a74b584100336509525ae7cadc6112d0c27e3d8704f3810e18f583d3cc33fa266bfec96db023607622b22ddbf17988ec4bf1bb3b3b9b2
+EBUILD isa-l-2.30.0-r1.ebuild 914 BLAKE2B 0c53cc62149cf67e2aa0cc7cebf8017f6f04670c183efbac360cdd110744e3dccf3152d62fccfa0a26da67017daa04b337145f52fe5df95d94a06ed38abb8109 SHA512 6f9501b6e2fe84669706d56cf9db0723ef9b4607e53a2382d6b44de2b45aae615d99a645a74e7f536412bd82ae196f15902957c017038c37a4c923da3fc90457
+MISC metadata.xml 1002 BLAKE2B 2934e906f4d5a6afd5de680fefc934d46f8730fba062834b0d63ca58b0c7cab684daea9c3adafd8e00e44efa7fa09547f8602b724b5cebb557d4ffff1eaf4615 SHA512 6cbf77704f202e8748348b3ee95295ab7d3def3ddf07ede18f4dafdc4374685b7597892d2ba02eaf2d113abeb6f6ece282f8f822528eecd6871c7c0faedcce28
diff --git a/dev-libs/isa-l/files/isa-l-2.30.0_makefile-no-D.patch b/dev-libs/isa-l/files/isa-l-2.30.0_makefile-no-D.patch
new file mode 100644
index 000000000000..98c37f3cc42f
--- /dev/null
+++ b/dev-libs/isa-l/files/isa-l-2.30.0_makefile-no-D.patch
@@ -0,0 +1,16 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -142,11 +142,11 @@
+ EXTRA_DIST += tools/yasm-filter.sh tools/nasm-filter.sh
+ EXTRA_DIST += tools/yasm-cet-filter.sh tools/nasm-cet-filter.sh
+
+-AM_CFLAGS = ${my_CFLAGS} ${INCLUDE} $(src_include) ${D}
++AM_CFLAGS = ${my_CFLAGS} ${INCLUDE} $(src_include) ${DIST_D}
+ if CPU_AARCH64
+ AM_CCASFLAGS = ${AM_CFLAGS}
+ else
+-AM_CCASFLAGS = ${yasm_args} ${INCLUDE} ${src_include} ${DEFS} ${D}
++AM_CCASFLAGS = ${yasm_args} ${INCLUDE} ${src_include} ${DEFS} ${DIST_D}
+ endif
+
+ .asm.s:
diff --git a/dev-libs/isa-l/isa-l-2.30.0-r1.ebuild b/dev-libs/isa-l/isa-l-2.30.0-r1.ebuild
new file mode 100644
index 000000000000..793f5856db3f
--- /dev/null
+++ b/dev-libs/isa-l/isa-l-2.30.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Intelligent Storage Acceleration Library"
+HOMEPAGE="https://github.com/intel/isa-l"
+SRC_URI="https://github.com/intel/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="cpu_flags_x86_avx512f"
+
+# AVX512 support in yasm is still work in progress
+BDEPEND="amd64? (
+ cpu_flags_x86_avx512f? ( >=dev-lang/nasm-2.13 )
+ !cpu_flags_x86_avx512f? ( || (
+ >=dev-lang/nasm-2.11.01
+ >=dev-lang/yasm-1.2.0
+ ) )
+)"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.30.0_makefile-no-D.patch
+)
+
+src_prepare() {
+ default
+
+ # isa-l does not support arbitrary assemblers on amd64 (and presumably x86),
+ # it must be either nasm or yasm.
+ use amd64 && unset AS
+
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/dev-libs/isa-l/metadata.xml b/dev-libs/isa-l/metadata.xml
new file mode 100644
index 000000000000..79b2a15f343d
--- /dev/null
+++ b/dev-libs/isa-l/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <longdescription>
+ ISA-L is a collection of optimized low-level functions targeting storage applications. ISA-L includes:
+ * Erasure codes - Fast block Reed-Solomon type erasure codes for any encode/decode matrix in GF(2^8).
+ * CRC - Fast implementations of cyclic redundancy check. Six different polynomials supported.
+ * iscsi32, ieee32, t10dif, ecma64, iso64, jones64.
+ * Raid - calculate and operate on XOR and P+Q parity found in common RAID implementations.
+ * Compression - Fast deflate-compatible data compression.
+ * De-compression - Fast inflate-compatible data compression.
+ * igzip - A command line application like gzip, accelerated with ISA-L.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">intel/isa-l</remote-id>
+ </upstream>
+</pkgmetadata>