summaryrefslogtreecommitdiff
path: root/dev-libs/intel-neo/intel-neo-21.31.20514.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /dev-libs/intel-neo/intel-neo-21.31.20514.ebuild
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'dev-libs/intel-neo/intel-neo-21.31.20514.ebuild')
-rw-r--r--dev-libs/intel-neo/intel-neo-21.31.20514.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-libs/intel-neo/intel-neo-21.31.20514.ebuild b/dev-libs/intel-neo/intel-neo-21.31.20514.ebuild
deleted file mode 100644
index d3597b338c00..000000000000
--- a/dev-libs/intel-neo/intel-neo-21.31.20514.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-MY_PN="compute-runtime"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Intel Graphics Compute Runtime for L0 and OpenCL, for Broadwell and beyond"
-HOMEPAGE="https://github.com/intel/compute-runtime"
-SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}"/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="l0 vaapi"
-
-RDEPEND=">=virtual/opencl-3
- >=dev-util/intel-graphics-compiler-1.0.8173
- >=media-libs/gmmlib-21.2.1
- l0? ( >=dev-libs/level-zero-1.4.1 )
- vaapi? (
- x11-libs/libdrm[video_cards_intel]
- x11-libs/libva
- )"
-DEPEND="${RDEPEND}
- media-libs/mesa" # for Khronos OpenGL headers
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-21.31.20514-no_Werror.patch
-)
-
-DOCS=(
- README.md
- FAQ.md
-)
-
-src_configure() {
- local mycmakeargs=(
- -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
- -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
- -DBUILD_WITH_L0=$(usex l0)
- -DDISABLE_LIBVA=$(usex vaapi "no" "yes")
- # If enabled, tests are automatically run during the compile phase
- # - and we cannot run them because they require permissions to access
- # the hardware.
- -DSKIP_UNIT_TESTS=ON
- )
- cmake_src_configure
-}