summaryrefslogtreecommitdiff
path: root/dev-libs/intel-compute-runtime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-02 23:47:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-02 23:47:16 +0100
commitd0855bf65db64f2452deea64fe76e06eaac9987c (patch)
tree42bdcad5ef28a19abde4b7e4ca89410b6b6e420a /dev-libs/intel-compute-runtime
parent19ad4b65c8b02065c065c91941241f231f78246c (diff)
gentoo auto-resync : 02:10:2023 - 23:47:15
Diffstat (limited to 'dev-libs/intel-compute-runtime')
-rw-r--r--dev-libs/intel-compute-runtime/Manifest2
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-23.35.27191.9.ebuild82
2 files changed, 84 insertions, 0 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
index 9416260446b3..5a9480e9c818 100644
--- a/dev-libs/intel-compute-runtime/Manifest
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -1,4 +1,6 @@
AUX intel-compute-runtime-22.24.23453-remove-fortify-sources.patch 1078 BLAKE2B 933cd6b5b3f9aefde4b416960151458eb7845f422e493ab40257330c88b55e1866cf0ff59338ec708d705750ca88c87d54014d51d9492c3dadba7525b523ab56 SHA512 ee831418acb9ba5deba95dc2e013119a0cfe7db533710108063dc67cd0a4030a4419bbad0a007fdab445eba14036fdcae26ea0b4ce675ebb20f402620b880de8
DIST intel-compute-runtime-23.22.26516.18.tar.gz 6695812 BLAKE2B c413d0ee70564292122d3eb125669ffc0a0dd7491ec208688055a71173b4112db6da96934cd16c91c4ff1a932cf8fdea490c5d849d98c7171bc916d6d77dc837 SHA512 5949866da0c3e48582636b9260e9ee6321c06db543a30e8567310add1b93a7b37ee3e4f35dcd5d9a6f611ed701daa52fac98ae2c11e26809f3fe7da84d289fc3
+DIST intel-compute-runtime-23.35.27191.9.tar.gz 6856146 BLAKE2B 02676adde05bef374f12ca6d6baac1a577ae32b712e77bf01e09d6cc01a2eeeb4d6eacc8fb302e350aca34f9d70f07a20ac70a52a682bdefb06223c4b6611cf7 SHA512 39abd4830ce379894bd9f17e2a1685b6403ddd13bae1fb1549c11de3e4b26536adfb24194c245466c45ba01c9d89c5d69bb60fbb498d9c23c24d31b018a37af8
EBUILD intel-compute-runtime-23.22.26516.18.ebuild 1993 BLAKE2B 71b0d7c3df355513df78e0598d0d2b61ccd87c4cd0cc4cb5c3ed0a3ac8b7daf259e43fef04c8a47b5e3b95e37d520f25adf80ca7d788d7e05bbf9f33f2fd614f SHA512 b6537c1a27c4b92189fc8cca677c4f3156d6c9efbc720e2a848107aa1d3f4ab5b2e472b18009a2f40303341c76d4c829e4984e0ac44ec15d41b20dca1a8e87f5
+EBUILD intel-compute-runtime-23.35.27191.9.ebuild 1994 BLAKE2B 7582539aa87be9e697aef1407fdb1401ee967f9fe0528e90401dda2fd983948f580015750f2ec600da17ab255c2cf4559fe6861c27f51431a46b480f262be13a SHA512 16a62654caf710e8f266a02d27de557b5ea30b768b1cdacd544b683b3bb171b6b1a12920cff9c11d6c2f2c21feeffa57d983c1fd7c7a0be8d2bbdcc801240701
MISC metadata.xml 1429 BLAKE2B 6c2fde2fda8cd6b9d707c400c5b4d38e3d74dd73617faa9dd80f84100d499182ea959e695a473d32307914e76a26bae531a92677f0e4bedbdf05fc1cbd3095ff SHA512 ac61568ad36df6f6c8470b43f32d048930e4a569ec86d58ff563a86ae748f6bddb8700de487e4967da4998160f1c01517be0817cccc445a821984aff36617b6d
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-23.35.27191.9.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-23.35.27191.9.ebuild
new file mode 100644
index 000000000000..5d8dd8c58fab
--- /dev/null
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-23.35.27191.9.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_BUILD_TYPE="Release"
+MY_PN="${PN/intel-/}"
+MY_P="${MY_PN}-${PV}"
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+l0 +vaapi"
+
+RDEPEND=">=media-libs/gmmlib-22.3.5:="
+
+DEPEND="
+ ${DEPEND}
+ dev-libs/intel-metrics-discovery:=
+ dev-libs/intel-metrics-library:=
+ dev-libs/libnl:3
+ dev-libs/libxml2:2
+ >=dev-util/intel-graphics-compiler-1.0.15136.4
+ >=dev-util/intel-graphics-system-controller-0.8.13:=
+ media-libs/mesa
+ >=virtual/opencl-3
+ l0? ( >=dev-libs/level-zero-1.14.0:= )
+ vaapi? (
+ x11-libs/libdrm[video_cards_intel]
+ media-libs/libva
+ )
+"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "README.md" "FAQ.md" )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-22.24.23453-remove-fortify-sources.patch"
+)
+
+src_prepare() {
+ # Remove '-Werror' from default
+ sed -e '/Werror/d' -i CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # See https://github.com/intel/compute-runtime/issues/531
+ filter-lto
+
+ local mycmakeargs=(
+ -DCCACHE_ALLOWED="OFF"
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
+ -DBUILD_WITH_L0="$(usex l0)"
+ -DDISABLE_LIBVA="$(usex !vaapi)"
+ -DNEO__METRICS_LIBRARY_INCLUDE_DIR="${ESYSROOT}/usr/include"
+ -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
+ -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
+ -DSUPPORT_DG1="ON"
+ -Wno-dev
+
+ # See https://github.com/intel/intel-graphics-compiler/issues/204
+ # -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DSKIP_UNIT_TESTS="1"
+ )
+
+ cmake_src_configure
+}