summaryrefslogtreecommitdiff
path: root/dev-libs/intel-compute-runtime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-06 01:20:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-06 01:20:42 +0100
commita4f9ab81d6cbfc3ff649dd3577e3efa700b47387 (patch)
tree1c6cf78322fbf3379d5b7e4f4b836a42c5fddd19 /dev-libs/intel-compute-runtime
parenta4e37a9aeeef82eba5858dbc609f65b838b0f836 (diff)
gentoo auto-resync : 06:10:2022 - 01:20:42
Diffstat (limited to 'dev-libs/intel-compute-runtime')
-rw-r--r--dev-libs/intel-compute-runtime/Manifest2
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-22.39.24347.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
index 063f2078ee61..896b4f6babb3 100644
--- a/dev-libs/intel-compute-runtime/Manifest
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -1,4 +1,6 @@
AUX intel-compute-runtime-22.24.23453-remove-fortify-sources.patch 1078 BLAKE2B 933cd6b5b3f9aefde4b416960151458eb7845f422e493ab40257330c88b55e1866cf0ff59338ec708d705750ca88c87d54014d51d9492c3dadba7525b523ab56 SHA512 ee831418acb9ba5deba95dc2e013119a0cfe7db533710108063dc67cd0a4030a4419bbad0a007fdab445eba14036fdcae26ea0b4ce675ebb20f402620b880de8
DIST intel-compute-runtime-22.35.24055.tar.gz 5710106 BLAKE2B a8efab3ab078b2bc3bc85110fc13f5f68cecd8e9e6978a0f6298d37eb470264303579a66a2bc840b8a8719ef03d67474f4d8959e6bf9442ffb997de1ad1af43b SHA512 c6a238a238647ff79c8ac7a38ebba3e1913f3b6f2ec1adbdde9b8eb9536078de12eac8b35ba45e77eea156b3ec1bd55d8b1279b1fbe729be23429b88de5a757f
+DIST intel-compute-runtime-22.39.24347.tar.gz 5774278 BLAKE2B 27a288470f852ec87fae95a946fb87c9850cfc03e99bb869ebd474043d06f8b7beb2873b49d8fe4cc26f7db298c64d7b76d6bda6e6618c1ee8d1a9b658d5f45d SHA512 aef167fd4cc31d32c411ab54cf5f0e5fe13cda7e8fe4eac6aa3f9bf391b7ce9d51033d986d9c5e854c8f1492cce5022463e4b8b0ddc49319ef7bf362435808d5
EBUILD intel-compute-runtime-22.35.24055.ebuild 1982 BLAKE2B 20c0fda1c683d65e213d3f492b392a1826cb6f3eeca283819edc68eccea16530812ab6d636dc876cd4d3f814c76bd51baa97f64c979e04a430f6e04478170842 SHA512 9216c791966c11977c4f9ab3d7a280158f620c28fefbd2e0ab8c4086bbc09d93f331e090bd2a6e64b7f6f1af1154c0f25279b32e82b6a6e02e09bddaf2d3ac94
+EBUILD intel-compute-runtime-22.39.24347.ebuild 1985 BLAKE2B 81090beb26af0004523ae82544601fb4d13f9d25c6a66d6db22efb77a9beabc85f9f5eed91c4dc2811972e46b6bec43ad73daffe0d0fb36d1322a44c08888865 SHA512 d5fba2d0de4361c057c6d352a1efbb7bd3cb2dc5a8dde4ca68fde605766b8f300346cb580c35f023f912238ae18e628a153912596748852af312be9ecafc8d3c
MISC metadata.xml 1429 BLAKE2B 6c2fde2fda8cd6b9d707c400c5b4d38e3d74dd73617faa9dd80f84100d499182ea959e695a473d32307914e76a26bae531a92677f0e4bedbdf05fc1cbd3095ff SHA512 ac61568ad36df6f6c8470b43f32d048930e4a569ec86d58ff563a86ae748f6bddb8700de487e4967da4998160f1c01517be0817cccc445a821984aff36617b6d
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.39.24347.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.39.24347.ebuild
new file mode 100644
index 000000000000..180eda0de0fe
--- /dev/null
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.39.24347.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_BUILD_TYPE="Release"
+MY_PN="${PN/intel-/}"
+MY_P="${MY_PN}-${PV}"
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+l0 +vaapi"
+
+RDEPEND=">=media-libs/gmmlib-22.1.7:="
+
+DEPEND="
+ ${DEPEND}
+ >=dev-libs/intel-metrics-library-0_pre20220930:=
+ dev-libs/libnl:3
+ dev-libs/libxml2:2
+ >=dev-util/intel-graphics-compiler-1.0.12149.1
+ >=dev-util/intel-graphics-system-controller-0.8.4:=
+ media-libs/mesa
+ >=virtual/opencl-3
+ l0? ( >=dev-libs/level-zero-1.8.5:= )
+ vaapi? (
+ x11-libs/libdrm[video_cards_intel]
+ x11-libs/libva
+ )
+"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "README.md" "FAQ.md" )
+
+PATCHES=( "${FILESDIR}/${PN}-22.24.23453-remove-fortify-sources.patch" )
+
+src_prepare() {
+ # Remove '-Werror' from default
+ sed -e '/Werror/d' -i CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # See https://github.com/intel/compute-runtime/issues/531
+ filter-flags -flto=* -flto
+
+ local mycmakeargs=(
+ -DCCACHE_ALLOWED="OFF"
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
+ -DBUILD_WITH_L0="$(usex l0)"
+ -DDISABLE_LIBVA="$(usex !vaapi)"
+ -DNEO__METRICS_LIBRARY_INCLUDE_DIR="${ESYSROOT}/usr/include"
+ -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
+ -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
+ -DSUPPORT_DG1="ON"
+ -Wno-dev
+
+ # See https://github.com/intel/intel-graphics-compiler/issues/204
+ # -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DSKIP_UNIT_TESTS="1"
+ )
+
+ cmake_src_configure
+}