summaryrefslogtreecommitdiff
path: root/dev-libs/input-pad
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/input-pad
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/input-pad')
-rw-r--r--dev-libs/input-pad/Manifest3
-rw-r--r--dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild52
-rw-r--r--dev-libs/input-pad/metadata.xml15
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-libs/input-pad/Manifest b/dev-libs/input-pad/Manifest
new file mode 100644
index 000000000000..00ce7a43a305
--- /dev/null
+++ b/dev-libs/input-pad/Manifest
@@ -0,0 +1,3 @@
+DIST input-pad-1.0.99.20140916.tar.gz 621070 BLAKE2B 93de9327cefc9df883720c1f9aa977c1220580b8b003082c5a84e511c8b83ecd632a45a6b1b86656bf8cc86e818c97cac69d604688eba569dc831488660aabbd SHA512 a7dd7996f69dbb6cc200be3c181e82ef8d701f85f1b27a886a8910afb3e673c1d71878e70b79141570a28a31dd47565868a990a358058ae8b99c29c76a316261
+EBUILD input-pad-1.0.99_pre20140916.ebuild 1098 BLAKE2B fe51f3eb92681985d05e9b012e540887da1c6aad7dbec017a70a70740d454793c92bbd78f597de51dd156aefd38167de38a8524e1264388d323b8d81cbd738a5 SHA512 18a9a03a3f626e2135096ebda56ae3303ab5d1efb2e4b653ff53f95efea421e8be9bcef80997124afd7c4323f58581d627d221b34b0da2efcb30c627edbd0097
+MISC metadata.xml 503 BLAKE2B 6cb4521098d6415ede355e21c182363e674fa1407bcf5b4000dfc9f8f182a556c1617fca0b24f6c9ceaa9e2344c999f26c3bf4cafe029c761f2266f7ad4d15a5 SHA512 da6ac24e8d5e575dadabe7e11c128203b8ee16b72297569cf5c3e8071ef85a297bad2b9c1ec634c27909cf88e051bc4f73dc1fb24070ed5789a05bcfd913ce35
diff --git a/dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild b/dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild
new file mode 100644
index 000000000000..f884a5d7fb2b
--- /dev/null
+++ b/dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit ltprune xdg-utils
+
+MY_P="${P/_pre/.}"
+MY_PV="${PV/_pre/.}"
+
+DESCRIPTION="On-screen input pad to send characters with mouse"
+HOMEPAGE="https://github.com/fujiwarat/input-pad/wiki"
+SRC_URI="https://github.com/fujiwarat/${PN}/releases/download/${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="eekboard +introspection static-libs +xtest"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/libxml2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libxkbfile
+ x11-libs/libxklavier
+ virtual/libintl
+ eekboard? ( dev-libs/eekboard )
+ introspection? ( dev-libs/gobject-introspection )
+ xtest? ( x11-libs/libXtst )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+}
+
+src_configure() {
+ econf \
+ $(use_enable eekboard eek) \
+ $(use_enable introspection) \
+ $(use_enable static-libs static) \
+ $(use_enable xtest)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/dev-libs/input-pad/metadata.xml b/dev-libs/input-pad/metadata.xml
new file mode 100644
index 000000000000..fc144ccafd3d
--- /dev/null
+++ b/dev-libs/input-pad/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <use>
+ <flag name="eekboard">Enable support for <pkg>dev-libs/eekboard</pkg></flag>
+ <flag name="xtest">Enable support for <pkg>x11-libs/libXtst</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="github">fujiwarat/input-pad</remote-id>
+ </upstream>
+</pkgmetadata>