summaryrefslogtreecommitdiff
path: root/dev-libs/input-pad
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-libs/input-pad
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-libs/input-pad')
-rw-r--r--dev-libs/input-pad/Manifest4
-rw-r--r--dev-libs/input-pad/files/input-pad-Wreturn-type.patch23
-rw-r--r--dev-libs/input-pad/files/input-pad-man.patch23
-rw-r--r--dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild19
4 files changed, 61 insertions, 8 deletions
diff --git a/dev-libs/input-pad/Manifest b/dev-libs/input-pad/Manifest
index 00ce7a43a305..db5419d05ae3 100644
--- a/dev-libs/input-pad/Manifest
+++ b/dev-libs/input-pad/Manifest
@@ -1,3 +1,5 @@
+AUX input-pad-Wreturn-type.patch 685 BLAKE2B 7b546e11b055214aed8d210033726c6cf37cca82b78e34674b4dab8313b15aff8034598b03cc5ea209beb63fcba410d0dd2b64ec456b288102545edd221108af SHA512 33b5eddfbe7ae0f88202b78d4d82b62e9ea0afa23ee547c32f750bd247621b74b466acfe9d570b0709f167444f9b9d54c43b13f8243356b645e42f3dc7d56307
+AUX input-pad-man.patch 664 BLAKE2B 7e62f50a0c60a0962d6098d7272cc4838c423d8a6b154d8f3b8d8a75d237c63d4171cae445c6ebf0fe97304be829a037d9e32ea46b2e53725282bfebcaacd56c SHA512 8521b2fdbbc36ab6daebc1783f28b3655cb76c5d42d0b05f5daba43be99e670c5471d643a3987906b4707818576923176cfd6d31405ce50027984d6bbc5dc8ec
DIST input-pad-1.0.99.20140916.tar.gz 621070 BLAKE2B 93de9327cefc9df883720c1f9aa977c1220580b8b003082c5a84e511c8b83ecd632a45a6b1b86656bf8cc86e818c97cac69d604688eba569dc831488660aabbd SHA512 a7dd7996f69dbb6cc200be3c181e82ef8d701f85f1b27a886a8910afb3e673c1d71878e70b79141570a28a31dd47565868a990a358058ae8b99c29c76a316261
-EBUILD input-pad-1.0.99_pre20140916.ebuild 1098 BLAKE2B fe51f3eb92681985d05e9b012e540887da1c6aad7dbec017a70a70740d454793c92bbd78f597de51dd156aefd38167de38a8524e1264388d323b8d81cbd738a5 SHA512 18a9a03a3f626e2135096ebda56ae3303ab5d1efb2e4b653ff53f95efea421e8be9bcef80997124afd7c4323f58581d627d221b34b0da2efcb30c627edbd0097
+EBUILD input-pad-1.0.99_pre20140916.ebuild 1210 BLAKE2B 9c56990850200dfdbc8026cfd6e8442c94c550b0a9313300b1b4ec72ee59cfa05aa3300858ea506117a6b97f0a900846635a89c277134f23bf3e51ac498d0bb1 SHA512 e49e7634703d5b05e31122c57f6f53ec981042834554c25fbaaecced72eb4ffc38cbbf4fbe0191183273366b730ca9010a50b749714bdebc6a057b5cced26887
MISC metadata.xml 503 BLAKE2B 6cb4521098d6415ede355e21c182363e674fa1407bcf5b4000dfc9f8f182a556c1617fca0b24f6c9ceaa9e2344c999f26c3bf4cafe029c761f2266f7ad4d15a5 SHA512 da6ac24e8d5e575dadabe7e11c128203b8ee16b72297569cf5c3e8071ef85a297bad2b9c1ec634c27909cf88e051bc4f73dc1fb24070ed5789a05bcfd913ce35
diff --git a/dev-libs/input-pad/files/input-pad-Wreturn-type.patch b/dev-libs/input-pad/files/input-pad-Wreturn-type.patch
new file mode 100644
index 000000000000..2e50f8bce2b0
--- /dev/null
+++ b/dev-libs/input-pad/files/input-pad-Wreturn-type.patch
@@ -0,0 +1,23 @@
+--- a/input-pad/window-gtk.c
++++ b/input-pad/window-gtk.c
+@@ -5462,7 +5462,7 @@
+
+ app = INPUT_PAD_GTK_APPLICATION (window_data);
+
+- g_return_if_fail (app->window != NULL);
++ g_return_val_if_fail (app->window != NULL, 0);
+
+ return gtk_widget_get_visible (GTK_WIDGET (app->window));
+ }
+@@ -5661,8 +5661,9 @@
+ {
+ InputPadGtkApplication *app;
+
+- g_return_if_fail (window_data != NULL &&
+- INPUT_PAD_IS_GTK_APPLICATION (window_data));
++ g_return_val_if_fail (window_data != NULL &&
++ INPUT_PAD_IS_GTK_APPLICATION (window_data),
++ -1);
+
+ app = INPUT_PAD_GTK_APPLICATION (window_data);
+
diff --git a/dev-libs/input-pad/files/input-pad-man.patch b/dev-libs/input-pad/files/input-pad-man.patch
new file mode 100644
index 000000000000..f54580f776ed
--- /dev/null
+++ b/dev-libs/input-pad/files/input-pad-man.patch
@@ -0,0 +1,23 @@
+--- a/input-pad/Makefile.am
++++ b/input-pad/Makefile.am
+@@ -226,19 +226,15 @@
+ endif
+
+ man_one_in_files = input-pad.1.in
+-man_one_files = $(man_one_in_files:.1.in=.1)
+-man_one_DATA =$(man_one_files:.1=.1.gz)
++man_one_DATA = $(man_one_in_files:.1.in=.1)
+ man_onedir = $(mandir)/man1
+ %.1: %.1.in
+ $(AM_V_GEN) sed \
+ -e 's|@VERSION[@]|$(VERSION)|g' $< > $@.tmp && \
+ mv $@.tmp $@
+-%.1.gz: %.1
+- $(AM_V_GEN) gzip -c $< > $@.tmp && mv $@.tmp $@
+
+ CLEANFILES += \
+ $(BUILT_SOURCES) \
+- $(man_one_files) \
+ $(man_one_DATA) \
+ $(NULL)
+
diff --git a/dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild b/dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild
index f884a5d7fb2b..2294addb77a2 100644
--- a/dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild
+++ b/dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
-inherit ltprune xdg-utils
+inherit autotools
MY_P="${P/_pre/.}"
MY_PV="${PV/_pre/.}"
@@ -27,15 +27,20 @@ RDEPEND="dev-libs/glib:2
eekboard? ( dev-libs/eekboard )
introspection? ( dev-libs/gobject-introspection )
xtest? ( x11-libs/libXtst )"
-DEPEND="${RDEPEND}
- dev-util/intltool
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/intltool
sys-devel/gettext
virtual/pkgconfig"
S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-Wreturn-type.patch
+ "${FILESDIR}"/${PN}-man.patch
+)
+
src_prepare() {
default
- xdg_environment_reset
+ eautoreconf
}
src_configure() {
@@ -48,5 +53,5 @@ src_configure() {
src_install() {
default
- prune_libtool_files
+ use static-libs || find "${ED}" -name '*.la' -delete || die
}