summaryrefslogtreecommitdiff
path: root/dev-libs/inih
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-libs/inih
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-libs/inih')
-rw-r--r--dev-libs/inih/Manifest2
-rw-r--r--dev-libs/inih/inih-55.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/inih/Manifest b/dev-libs/inih/Manifest
index e5d9a92bc0e5..9e8d785e6325 100644
--- a/dev-libs/inih/Manifest
+++ b/dev-libs/inih/Manifest
@@ -1,3 +1,5 @@
DIST inih-53.tar.gz 16984 BLAKE2B 1242e6273c9dd9a11ea026a3495a487b2aa72d8e01f34304d8568c88897ae9c9bb425246f992dc16f4dc2210ec14c597d0ef595cec84ff98a5d6101ee5a643b9 SHA512 99bc40c294b521e9973184bfb30d60c129735991f33b387b3d023827a34672b0489eadf91e38895ea725168dbc7b27bb02c1975debe7573b4b209d0e947b2100
+DIST inih-55.tar.gz 18219 BLAKE2B 28b5e04e54e31b3e0392b44799a2c2e75c1fe00527491a857480b7e960302f2438d29652b131dae5147487c863d93f577b67aeff3ab5f863546d3661628d8236 SHA512 bcbef361a4400da017dbed811ad21672b58512d2b2b537cc0058cdeca709dd0d5a9def4045ce1c1972873c3d3d35182123337e4388676f6f0d16e8dbff967b0f
EBUILD inih-53.ebuild 747 BLAKE2B 5694c1e0baae77e8bd82fbd66a96b641eee7fb4178100bcab61b9ee024a101506082d93625890f03adb793a71f63c93e81dd61ed43ea975ffade70aba6e5ff12 SHA512 f44c07465946ceae89fbfe11ef379145bf77c5cc8b33f9934405e3e2202f0d7c1040d1f6f1ca507d52d2c27d7c52fb268be75c10852ce9569b871ede0712ba6c
+EBUILD inih-55.ebuild 767 BLAKE2B 04d534baf6ef853122db7848ce278efb3a50be766a3cdc905d0e276c1c26c0c30a59b4273d9d2b9aa983399a8e1d1785e3ec1657e51f658b72fed03842c3aa7b SHA512 693b5899621026539e5594a869b0de424ae6f00913e40625888fedb449adff3bd7c80571e909e4a5f86d7a0241ab63ba70db4833f463a3da7614f26f0645883f
MISC metadata.xml 520 BLAKE2B d067b0d423cb2ecdeee888a8b6588c1ee3a47d9080a83d0288736fd31d2521956e6dfb970d612ca27f3c9da8103f37e3dd3245eba9b57f9a1ce4d8631695da14 SHA512 47fafee9e35a1827b8d68ab35fea44e8895658dbdd77628f03d31160bbeb915e2cdad81a17c0530d3b0de713fd141999949992feb4c98fabf2ed9bcf717e6b1f
diff --git a/dev-libs/inih/inih-55.ebuild b/dev-libs/inih/inih-55.ebuild
new file mode 100644
index 000000000000..aaed5ec77fd5
--- /dev/null
+++ b/dev-libs/inih/inih-55.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Tests not wired up to meson and don't seem to be intended for downstream use yet
+# e.g. hardcoding gcc, just a shell script
+
+inherit meson-multilib
+
+DESCRIPTION="inih (INI not invented here) simple .INI file parser"
+HOMEPAGE="https://github.com/benhoyt/inih"
+
+SRC_URI="https://github.com/benhoyt/inih/archive/r${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+S="${WORKDIR}/inih-r${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+
+DOCS=( README.md )
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library=shared
+ -Ddistro_install=true
+ -Dwith_INIReader=true
+ )
+
+ meson_src_configure
+}