summaryrefslogtreecommitdiff
path: root/dev-libs/inih
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-libs/inih
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-libs/inih')
-rw-r--r--dev-libs/inih/Manifest4
-rw-r--r--dev-libs/inih/inih-52.ebuild43
-rw-r--r--dev-libs/inih/metadata.xml8
3 files changed, 50 insertions, 5 deletions
diff --git a/dev-libs/inih/Manifest b/dev-libs/inih/Manifest
index e483b1ed59e1..91afa01fa501 100644
--- a/dev-libs/inih/Manifest
+++ b/dev-libs/inih/Manifest
@@ -1,3 +1,5 @@
DIST inih-51.tar.gz 16258 BLAKE2B 91a5aee6e0ecadf949fbf0b58bd2596bcb985c76fc9000a671d65cb5325c51dbb8bd945ccd7721b72dafafd11c70a9c84ad910768d0fc479e5491db8b7aacbd8 SHA512 eb2f58979d93e51a09326e6c187828643887ac1a239d4b12205567c7d87a671c9c49ca99db376c031d366bc680e579c30dcea9f3eb130ec802597411b2cb3cf4
+DIST inih-52.tar.gz 16808 BLAKE2B 12d4078ad7b6a4013ea77239c486fb7b5e9165252d4a67ee57d60fc72a98f15ca537b610c7b22841cc660e46bb424aa5c9b7ed1cf2462600a2aa58d40447ba90 SHA512 14c0d0dbd78efc99bec8df12067107d130eef8b124e0616f7d83dc4e14530b57f0c8fcf0b8862d425b5a0b84d6c6a6bff7b3c852c9b2e2364ef56c8f64a1f339
EBUILD inih-51.ebuild 733 BLAKE2B 35c324b1927627143e78e9f18e6121e5092541ac96ff10b17fe7717f546bce6ecbd8e0f0aea086a736543f44b2fcdcc3976b3f1364f8146c39fc279b1c0bc5da SHA512 a7f9767609347bd9618156e41815b13f88551e7531f4c6ba5df58caa362d2395aea12466dc19225e2e320dc893ef17d0b48e0dc7976d36a353a46bdffb616902
-MISC metadata.xml 504 BLAKE2B 9dbb7e8ce4c8524166a60e799e67d972a60297d48aeaaa572797303f23b599168a7d9fa061550287694c0243562ab4139aa48674704e65a5ac50339bfffbb0ba SHA512 bb42c3ff3e4b1ba3b3bc70b2f1d719c3ade733d2f4c8e90d98e20d2fd716a633b22e3a4212a29c56291e7fe6c475f0e540f37454302bc279342bbec95fbd320f
+EBUILD inih-52.ebuild 787 BLAKE2B 0b6ba6543c29e7ae552a0bd7883c4fcefa1cd287775f3a7dd1c46e0440030c90e2d6392b6fa520a5803383d11f700345b92da25d445e6865a9717b0e816667cc SHA512 850040ae3d1ca5ba4e2c0b5b9a2450d7b5aca45f8b10f0319206f26a355cd6152e579877f7e51d501dd4663134552400fea35d7d5f9cec9668ac11cf7e0b7df8
+MISC metadata.xml 505 BLAKE2B 304fa736140ec6ca3461e31f5629e22857ece165c6f16dbe4632211f05d2d4a45c2c9b5f35e858e81ae0d11cbdc87b3fc4977b55c0032cc115b65df43466242f SHA512 09e559083c0457cc38eae5efe344d035fbbbc860ae1ba268462ff821a467712d599c3cf7292d44f9a9f0d99674b0a1d6650e199147403686e859ee20d8fcdba3
diff --git a/dev-libs/inih/inih-52.ebuild b/dev-libs/inih/inih-52.ebuild
new file mode 100644
index 000000000000..643c90ef2a42
--- /dev/null
+++ b/dev-libs/inih/inih-52.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson multilib-minimal
+
+DESCRIPTION="inih (INI not invented here) simple .INI file parser"
+HOMEPAGE="https://github.com/benhoyt/inih"
+
+SRC_URI="https://github.com/benhoyt/inih/archive/r${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+LICENSE="BSD"
+SLOT="0"
+
+S="${WORKDIR}/inih-r${PV}"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library=shared
+ -Ddistro_install=true
+ -Dwith_INIReader=true
+ )
+
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_install() {
+ meson_src_install
+}
+
+multilib_src_install_all() {
+ local DOCS=(
+ LICENSE.txt
+ README.md
+ )
+ einstalldocs
+}
diff --git a/dev-libs/inih/metadata.xml b/dev-libs/inih/metadata.xml
index 9aa6590570ff..6d0bdb811ca7 100644
--- a/dev-libs/inih/metadata.xml
+++ b/dev-libs/inih/metadata.xml
@@ -1,14 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+ </maintainer>
<maintainer type="person">
<email>hurikhan77+bgo@gmail.com</email>
<name>Kai Krakow</name>
</maintainer>
- <maintainer type="project">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
<upstream>
<bugs-to>https://github.com/benhoyt/inih/issues</bugs-to>
<remote-id type="github">benhoyt/inih</remote-id>