summaryrefslogtreecommitdiff
path: root/dev-libs/inih
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /dev-libs/inih
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'dev-libs/inih')
-rw-r--r--dev-libs/inih/Manifest3
-rw-r--r--dev-libs/inih/inih-52-r1.ebuild45
-rw-r--r--dev-libs/inih/inih-52.ebuild4
3 files changed, 49 insertions, 3 deletions
diff --git a/dev-libs/inih/Manifest b/dev-libs/inih/Manifest
index 5351ce28b280..4421cafe5489 100644
--- a/dev-libs/inih/Manifest
+++ b/dev-libs/inih/Manifest
@@ -1,5 +1,6 @@
DIST inih-51.tar.gz 16258 BLAKE2B 91a5aee6e0ecadf949fbf0b58bd2596bcb985c76fc9000a671d65cb5325c51dbb8bd945ccd7721b72dafafd11c70a9c84ad910768d0fc479e5491db8b7aacbd8 SHA512 eb2f58979d93e51a09326e6c187828643887ac1a239d4b12205567c7d87a671c9c49ca99db376c031d366bc680e579c30dcea9f3eb130ec802597411b2cb3cf4
DIST inih-52.tar.gz 16808 BLAKE2B 12d4078ad7b6a4013ea77239c486fb7b5e9165252d4a67ee57d60fc72a98f15ca537b610c7b22841cc660e46bb424aa5c9b7ed1cf2462600a2aa58d40447ba90 SHA512 14c0d0dbd78efc99bec8df12067107d130eef8b124e0616f7d83dc4e14530b57f0c8fcf0b8862d425b5a0b84d6c6a6bff7b3c852c9b2e2364ef56c8f64a1f339
EBUILD inih-51.ebuild 733 BLAKE2B 35c324b1927627143e78e9f18e6121e5092541ac96ff10b17fe7717f546bce6ecbd8e0f0aea086a736543f44b2fcdcc3976b3f1364f8146c39fc279b1c0bc5da SHA512 a7f9767609347bd9618156e41815b13f88551e7531f4c6ba5df58caa362d2395aea12466dc19225e2e320dc893ef17d0b48e0dc7976d36a353a46bdffb616902
-EBUILD inih-52.ebuild 794 BLAKE2B 14c8b0be0afb88e5643107769c5ca12a1478eca793c20e87231b7e3773d5304fe5a47913c2b4f7d08bcff08f91b7381867ccb13f8593c9701898ad84ed4cd537 SHA512 2c405f7395e0927bf4e368767764581623c2b6f358af0172e06d95c22e5614714d2376c8321c2ca1d8ec4964bfe189108c8fcb82931e5f8bef6e538b33e9136a
+EBUILD inih-52-r1.ebuild 844 BLAKE2B 5d880d7a1ea62da459a61af8c12c078d2e848f8895f2f79335896b9ac0d79303af56c24eaf0d3c771b6ca032866712ef395134d5db5e53912656a9b2ae68eaa4 SHA512 03206b8707a8ad71e7f6a3fb5d5738030ae526abcd0518e0507cbb9e46db11d863b71c697eb34a1a0b4d38391792a4e29d358219b5e1c68f0d48144e40f11164
+EBUILD inih-52.ebuild 791 BLAKE2B 09983b3a0fecbc3bc76218f7852778282568682a355c2e9644205b8adb0efc6b4710e5611b08c674359ac828aaf8c7797788601f0eac5ac3b9b5854cc2f9a0c8 SHA512 6da75c3754efd2dcce6e7c24e13ed14880427d6291d2d01e35c15b4d67b1ffb2c2a9d390ed4b0c73e56b1593c1d31ca0ed91914543aa150b2bcc3eaacf8a8ef9
MISC metadata.xml 505 BLAKE2B 304fa736140ec6ca3461e31f5629e22857ece165c6f16dbe4632211f05d2d4a45c2c9b5f35e858e81ae0d11cbdc87b3fc4977b55c0032cc115b65df43466242f SHA512 09e559083c0457cc38eae5efe344d035fbbbc860ae1ba268462ff821a467712d599c3cf7292d44f9a9f0d99674b0a1d6650e199147403686e859ee20d8fcdba3
diff --git a/dev-libs/inih/inih-52-r1.ebuild b/dev-libs/inih/inih-52-r1.ebuild
new file mode 100644
index 000000000000..59b118e7afe5
--- /dev/null
+++ b/dev-libs/inih/inih-52-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson multilib-minimal
+
+DESCRIPTION="inih (INI not invented here) simple .INI file parser"
+HOMEPAGE="https://github.com/benhoyt/inih"
+
+SRC_URI="https://github.com/benhoyt/inih/archive/r${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+LICENSE="BSD"
+SLOT="0"
+
+IUSE="static-libs"
+
+S="${WORKDIR}/inih-r${PV}"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library=$(usex static-libs both shared)
+ -Ddistro_install=true
+ -Dwith_INIReader=true
+ )
+
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_install() {
+ meson_src_install
+}
+
+multilib_src_install_all() {
+ local DOCS=(
+ LICENSE.txt
+ README.md
+ )
+ einstalldocs
+}
diff --git a/dev-libs/inih/inih-52.ebuild b/dev-libs/inih/inih-52.ebuild
index 71d82e5d0f3f..09154cf1b6eb 100644
--- a/dev-libs/inih/inih-52.ebuild
+++ b/dev-libs/inih/inih-52.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -9,7 +9,7 @@ DESCRIPTION="inih (INI not invented here) simple .INI file parser"
HOMEPAGE="https://github.com/benhoyt/inih"
SRC_URI="https://github.com/benhoyt/inih/archive/r${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 s390 sparc x86"
LICENSE="BSD"
SLOT="0"