summaryrefslogtreecommitdiff
path: root/dev-libs/igraph
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/igraph
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/igraph')
-rw-r--r--dev-libs/igraph/Manifest4
-rw-r--r--dev-libs/igraph/files/igraph-0.7.1-unbundle.patch269
-rw-r--r--dev-libs/igraph/igraph-0.7.1-r2.ebuild46
-rw-r--r--dev-libs/igraph/metadata.xml14
4 files changed, 333 insertions, 0 deletions
diff --git a/dev-libs/igraph/Manifest b/dev-libs/igraph/Manifest
new file mode 100644
index 000000000000..8e84eeebf13c
--- /dev/null
+++ b/dev-libs/igraph/Manifest
@@ -0,0 +1,4 @@
+AUX igraph-0.7.1-unbundle.patch 8525 BLAKE2B 716137c2d7b4ffc3e29b484539867216574162dc3c55ea747c57cf24689ef3de032776f9e7f1d76cdb1c0e39bd6afd5fc3cc2e74de4209d632bdd568a8b884a4 SHA512 8b796f95044a231b2695532d158721cf48dfd266f5acfc2eec8a7f3706208190ee07eccaf83823ba9323edaef15afbca60ff7013cf0d9d7fda0ab5b0ee5e0eff
+DIST igraph-0.7.1.tar.gz 2967134 BLAKE2B 27f0a2f51e561a3ea2e2e6d31853fe10ffd66f9f67603d77f2c0449a4c2bcd4d45c98516b526fb0f23a871ebe3db1fcf0c691551714d044124778faa147bd30f SHA512 ac7d7e3fbc6d27ae69079224881ca03db2c7e0b50d016706f3e167c614e2c9332c675d2fcd3cde12874e13a8fc402d42222308c6195afadee15152cec93f94dd
+EBUILD igraph-0.7.1-r2.ebuild 902 BLAKE2B 6a443171f450d4958c0d6c4e8ad4c8d3b835ddfde10c4b472cfc3e04f8eb40477202fb0b05f4562efb13c08a8d3cd6822ff6140716b9ea304f5ab46579352013 SHA512 1542c66a97c5d070233d609a2ee08e797a8d9f178e4d6a4c34e8b1f9c1ebdbe01413cc5c87cd33c553449712e8472537f295178b2e89c610539d167035f98936
+MISC metadata.xml 603 BLAKE2B 996b695aa3f67e6bfbbed5a505c6aa08dd72c68911d3b881cf8d99c20439eabbf4d87fe714e0fb7363ee9870f389005b19943ff1ecf865dfb0f5a8936021850b SHA512 31eb84c71fc2afb1fb804f2fe94eafa4c0e0a37eb933b6c89c530e32bdcfa684512e4aff9c36a58d363df0ce6321eaa298a5d48778f93e8c8ad8fe7e31b5b152
diff --git a/dev-libs/igraph/files/igraph-0.7.1-unbundle.patch b/dev-libs/igraph/files/igraph-0.7.1-unbundle.patch
new file mode 100644
index 000000000000..755e749c1868
--- /dev/null
+++ b/dev-libs/igraph/files/igraph-0.7.1-unbundle.patch
@@ -0,0 +1,269 @@
+diff --git a/configure.ac b/configure.ac
+index acf76cd..a9db7bd 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -167,7 +167,8 @@ if test "x$enable_gmp" != "xno"; then
+ AC_CHECK_HEADER([gmp.h], [
+ AC_DEFINE([HAVE_GMP], [1], [Define to 1 if you have the GMP library])
+ gmp_support=yes
+- LDFLAGS="${LDFLAGS} -lgmp"
++ GMP_LIBS="-lgmp"
++ AC_SUBST(GMP_LIBS)
+ PKGCONFIG_LIBS_PRIVATE="${PKGCONFIG_LIBS_PRIVATE} -lgmp"
+ ])
+ ])
+@@ -231,24 +232,16 @@ else
+ fi
+
+ if test "$internal_blas" = "no"; then
+- AC_CHECK_LIB([blas], [daxpy_], [],
+- AC_CHECK_LIB([blas], [daxpy], [],
+- AC_CHECK_LIB([blas], [DAXPY_], [],
+- AC_CHECK_LIB([blas], [DAXPY], [],
+- [AC_MSG_RESULT(not found, trying to use -lblas anyway.)]))))
+- LDFLAGS="${LDFLAGS} -lblas"
++ PKG_CHECK_MODULES([BLAS],[blas])
++ CPPFLAGS="${CPPFLAGS} ${BLAS_CFLAGS}"
+ PKGCONFIG_LIBS_PRIVATE="${PKGCONFIG_LIBS_PRIVATE} -lblas"
+ else
+ AC_DEFINE([INTERNAL_BLAS], [1], [Define to 1 if you use the internal BLAS library])
+ fi
+
+ if test "$internal_lapack" = "no"; then
+- AC_CHECK_LIB([lapack], [dlarnv_], [],
+- AC_CHECK_LIB([lapack], [dlarnv], [],
+- AC_CHECK_LIB([lapack], [DLARNV_], [],
+- AC_CHECK_LIB([lapack], [DLARNV], [],
+- [AC_MSG_RESULT(not found, trying to use -llapack anyway.)]))))
+- LDFLAGS="${LDFLAGS} -llapack"
++ PKG_CHECK_MODULES([LAPACK],[lapack])
++ CPPFLAGS="${CPPFLAGS} ${LAPACK_CFLAGS}"
+ PKGCONFIG_LIBS_PRIVATE="${PKGCONFIG_LIBS_PRIVATE} -llapack"
+ else
+ AC_DEFINE([INTERNAL_LAPACK], [1], [Define to 1 if you use the internal LAPACK library])
+@@ -258,17 +251,15 @@ if test "$internal_arpack" = "no"; then
+ if test "$tls_support" = "yes"; then
+ AC_MSG_ERROR([Thread-local storage only supported with internal ARPACK library])
+ fi
+- AC_CHECK_LIB([arpack], [dsaupd_], [],
+- AC_CHECK_LIB([arpack], [dsaupd], [],
+- AC_CHECK_LIB([arpack], [DSAUPD_], [],
+- AC_CHECK_LIB([arpack], [DSAUPD], [],
+- [AC_MSG_RESULT(not found, trying to use -larpack anyway.)]))))
+- LDFLAGS="${LDFLAGS} -larpack"
++ PKG_CHECK_MODULES([ARPACK],[arpack])
++ CPPFLAGS="${CPPFLAGS} ${ARPACK_CFLAGS}"
+ PKGCONFIG_LIBS_PRIVATE="${PKGCONFIG_LIBS_PRIVATE} -larpack"
+ else
+ AC_DEFINE([INTERNAL_ARPACK], [1], [Define to 1 if you use the internal ARPACK library])
+ fi
+
++PKG_CHECK_MODULES([CS],[cxsparse])
++
+ glpk_support=no
+ AC_ARG_ENABLE(glpk, AC_HELP_STRING([--disable-glpk], [Compile without the GLPK library]))
+ if test "x$enable_glpk" != "xno"; then
+@@ -283,7 +274,8 @@ if test "x$enable_glpk" != "xno"; then
+ ], [
+ AC_DEFINE([HAVE_GLPK], [1], [Define to 1 if you have the GLPK library])
+ glpk_support=yes
+- LDFLAGS="${LDFLAGS} -lglpk"
++ GLPK_LIBS="-lglpk"
++ AC_SUBST(GLPK_LIBS)
+ PKGCONFIG_LIBS_PRIVATE="${PKGCONFIG_LIBS_PRIVATE} -lglpk"
+ ])
+ ])
+diff --git a/examples/simple/igraph_arpack_rnsolve.out b/examples/simple/igraph_arpack_rnsolve.out
+index ec38497..6603034 100644
+--- a/examples/simple/igraph_arpack_rnsolve.out
++++ b/examples/simple/igraph_arpack_rnsolve.out
+@@ -16,7 +16,7 @@
+ ---
+ 22.0483 0
+ -21.3281 0
+--3.00735 -19.2957
++-3.00735 19.2957
+ ---
+ 0.373224 0.226696 0.204213 0.0473383
+ -0.289145 -0.296079 -0.0479785 0.156365
+@@ -31,7 +31,7 @@
+ ---
+ -21.3281 0
+ -12.4527 0
+--3.00735 -19.2957
++-3.00735 19.2957
+ ---
+ -0.226696 0.695866 -0.204213 -0.0473383
+ 0.296079 0.120213 0.0479785 -0.156365
+@@ -46,7 +46,7 @@
+ ---
+ -3.00735 19.2957
+ -3.00735 -19.2957
+-12.1099 6.27293
++12.1099 -6.27293
+ ---
+ 0.0768616 -0.195028 -0.152389 0.21912
+ 0.147607 0.0704569 0.346547 0.125122
+diff --git a/examples/simple/igraph_layout_merge2.out b/examples/simple/igraph_layout_merge2.out
+index dfe2c22..9fe81bf 100644
+--- a/examples/simple/igraph_layout_merge2.out
++++ b/examples/simple/igraph_layout_merge2.out
+@@ -1,13 +1,13 @@
+--2.73912 -2.95429
+--0.479512 -4.00008
+-1.96326 -3.51798
+-3.65613 -1.69214
+-3.95248 0.780051
+-2.73912 2.95429
+-0.479512 4.00008
+--1.96326 3.51798
+--3.65613 1.69214
+--3.95248 -0.780051
++-2.55311 -3.13964
++-0.22007 -4.0407
++2.19703 -3.39835
++3.77493 -1.45795
++3.91094 1.03935
++2.55311 3.13964
++0.22007 4.0407
++-2.19703 3.39835
++-3.77493 1.45795
++-3.91094 -1.03935
+ -1.6061 6.30088
+ -4.92661 5.80435
+ -3.69637 8.92826
+diff --git a/examples/simple/igraph_sparsemat2.c b/examples/simple/igraph_sparsemat2.c
+index c39d0e5..fdfd264 100644
+--- a/examples/simple/igraph_sparsemat2.c
++++ b/examples/simple/igraph_sparsemat2.c
+@@ -21,7 +21,7 @@
+
+ */
+
+-#include <cs/cs.h>
++#include <cs.h>
+ #include <igraph.h>
+ #include <igraph_sparsemat.h>
+ #include <igraph_blas_internal.h>
+diff --git a/examples/simple/igraph_sparsemat3.c b/examples/simple/igraph_sparsemat3.c
+index 630bf1a..b23cbe1 100644
+--- a/examples/simple/igraph_sparsemat3.c
++++ b/examples/simple/igraph_sparsemat3.c
+@@ -21,7 +21,7 @@
+
+ */
+
+-#include <cs/cs.h>
++#include <cs.h>
+ #include <igraph.h>
+ #include <igraph_sparsemat.h>
+
+diff --git a/examples/simple/igraph_sparsemat4.c b/examples/simple/igraph_sparsemat4.c
+index 4d85bde..7497faf 100644
+--- a/examples/simple/igraph_sparsemat4.c
++++ b/examples/simple/igraph_sparsemat4.c
+@@ -21,7 +21,7 @@
+
+ */
+
+-#include <cs/cs.h>
++#include <cs.h>
+ #include <igraph.h>
+ #include <igraph_sparsemat.h>
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index e7085c5..194f4a0 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -9,9 +9,6 @@ AM_YFLAGS = -d
+
+ lib_LTLIBRARIES = libigraph.la
+
+-include lapack/blas.inc
+-include lapack/lapack.inc
+-include lapack/arpack.inc
+ include plfit/plfit.inc
+
+ F2C = f2c/abort_.c f2c/dolio.c f2c/r_sin.c\
+@@ -99,8 +96,6 @@ if INTERNAL_ARPACK
+ ARPACK_LIB = libarpack.la
+ endif
+
+-include ../optional/glpk/glpk.inc
+-
+ if INTERNAL_GLPK
+ libglpk_la_SOURCES = $(GLPK)
+ libglpk_la_CFLAGS = -I$(top_srcdir)/optional/glpk
+@@ -255,7 +250,7 @@ SOURCES = basic_query.c games.c cocitation.c iterators.c \
+ drl_layout_3d.cpp drl_graph_3d.cpp \
+ DensityGrid_3d.cpp \
+ foreign-dl-parser.y foreign-dl-lexer.l \
+- $(CS) sparsemat.c mixing.c bigint.c bignum.c \
++ sparsemat.c mixing.c bigint.c bignum.c \
+ version.c optimal_modularity.c \
+ igraph_fixed_vectorlist.c separators.c \
+ igraph_marked_queue.c igraph_estack.c st-cuts.c \
+@@ -274,8 +269,8 @@ libigraph_la_SOURCES = $(SOURCES) $(HEADERS_PRIVATE)
+ libigraph_la_CFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include $(WARNING_CFLAGS)
+ libigraph_la_CXXFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include $(WARNING_CFLAGS)
+ libigraph_la_LDFLAGS = -no-undefined
+-libigraph_la_LIBADD = -lm $(XML2_LIBS) $(F2C_LIB) $(BLAS_LIB) \
+- $(LAPACK_LIB) $(ARPACK_LIB) $(GLPK_LIB) $(PRPACK_LIB) \
++libigraph_la_LIBADD = -lm $(XML2_LIBS) $(F2C_LIB) $(BLAS_LIBS) $(GMP_LIBS) \
++ $(LAPACK_LIBS) $(ARPACK_LIBS) $(GLPK_LIBS) $(PRPACK_LIB) $(CS_LIBS) \
+ $(PLFIT_LIB)
+
+ if INTERNAL_GLPK
+diff --git a/src/sparsemat.c b/src/sparsemat.c
+index f96d022..6990c91 100644
+--- a/src/sparsemat.c
++++ b/src/sparsemat.c
+@@ -23,7 +23,7 @@
+
+ #include "config.h"
+
+-#include "cs/cs.h"
++#include "cs.h"
+
+ #include "igraph_sparsemat.h"
+ #include "igraph_error.h"
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 6da83b2..c0b82d6 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -13,7 +13,7 @@ $(srcdir)/package.m4: $(top_srcdir)/configure.ac
+ echo 'm4_define([AT_PACKAGE_BUGREPORT], [@PACKAGE_BUGREPORT@])'; \
+ } >$(srcdir)/package.m4
+
+-EXTRA_DIST += package.m4
++#EXTRA_DIST += package.m4
+
+ TESTSUITE_AT = \
+ testsuite.at \
+diff --git a/tests/mt.at b/tests/mt.at
+index 050974a..9558d6f 100644
+--- a/tests/mt.at
++++ b/tests/mt.at
+@@ -29,5 +29,5 @@ AT_CLEANUP
+ AT_SETUP([Thread-safe ARPACK:])
+ AT_KEYWORDS([thread-safe ARPACK])
+ AT_COMPILE_CHECK([simple/tls2.c], [simple/tls2.out], [], [internal],
+- [-lpthread])
++ [-lpthread $(${PKG_CONFIG} --libs arpack)])
+ AT_CLEANUP
+diff --git a/tests/types.at b/tests/types.at
+index f80a6a2..29ac739 100644
+--- a/tests/types.at
++++ b/tests/types.at
+@@ -133,7 +133,7 @@ AT_CLEANUP
+ AT_SETUP([Sparse matrix, multiplications (igraph_sparsemat_t): ])
+ AT_KEYWORDS([sparse matrix igraph_sparsemat_t])
+ AT_COMPILE_CHECK([simple/igraph_sparsemat2.c], [simple/igraph_sparsemat2.out],
+- [], [INTERNAL], [-lblas])
++ [], [INTERNAL], [$(${PKG_CONFIG} --libs blas)])
+ AT_CLEANUP
+
+ AT_SETUP([Sparse matrix, indexing (igraph_sparsemat_t): ])
+--
+2.0.0
+
diff --git a/dev-libs/igraph/igraph-0.7.1-r2.ebuild b/dev-libs/igraph/igraph-0.7.1-r2.ebuild
new file mode 100644
index 000000000000..83c2185d5b3e
--- /dev/null
+++ b/dev-libs/igraph/igraph-0.7.1-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Creating and manipulating undirected and directed graphs"
+HOMEPAGE="http://www.igraph.org/"
+SRC_URI="http://www.igraph.org/nightly/get/c/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug gmp"
+
+RDEPEND="
+ dev-libs/libxml2
+ >=sci-libs/arpack-3
+ virtual/blas
+ virtual/lapack
+ >=sci-libs/cxsparse-3
+ sci-mathematics/glpk
+ gmp? ( dev-libs/gmp:0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-unbundle.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ tc-export PKG_CONFIG
+ econf \
+ $(use_enable gmp) \
+ $(use_enable debug) \
+ --disable-tls \
+ --with-external-arpack \
+ --with-external-blas \
+ --with-external-lapack \
+ --with-external-f2c \
+ --with-external-glpk
+}
diff --git a/dev-libs/igraph/metadata.xml b/dev-libs/igraph/metadata.xml
new file mode 100644
index 000000000000..6ba23eeb564f
--- /dev/null
+++ b/dev-libs/igraph/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription lang="en">
+igraph is a free software package for creating and manipulating undirected and
+directed graphs. It includes implementations for classic graph theory problems
+like minimum spanning trees and network flow, and also implements algorithms for
+some recent network analysis methods, like community structure search.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">igraph</remote-id>
+ </upstream>
+</pkgmetadata>