summaryrefslogtreecommitdiff
path: root/dev-libs/igraph
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-23 02:57:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-23 02:57:53 +0100
commit24c53d42e0294f4f6e36fbb051891af86c9ae503 (patch)
treeb0af743b9df96807807fc6a16e77af239820b0c3 /dev-libs/igraph
parent351b26cfd42c558fa0f8eef51960c87bb0674026 (diff)
gentoo auto-resync : 23:05:2023 - 02:57:53
Diffstat (limited to 'dev-libs/igraph')
-rw-r--r--dev-libs/igraph/Manifest1
-rw-r--r--dev-libs/igraph/igraph-0.10.4-r1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/igraph/Manifest b/dev-libs/igraph/Manifest
index 979274f3ed36..b02b4dddcbba 100644
--- a/dev-libs/igraph/Manifest
+++ b/dev-libs/igraph/Manifest
@@ -1,3 +1,4 @@
DIST igraph-0.10.4.tar.gz 4279321 BLAKE2B 4e1fc8e8d6dd38cdb24ec564f51f2924e457376c258497b51d7dd4cec88d2226d5b202cdcfa69560e43fdb3cbd49656511178acd2ed705b4af26b1947a92f1ab SHA512 71bcec5f0ba100aae7614753f9232a4221580b822b4dc120e3a80eab59d70c42aedddb00728eb13faf7e522332c514c2e030314c416ded8a70e5de990ea8039b
+EBUILD igraph-0.10.4-r1.ebuild 1023 BLAKE2B 4550dc6a93d4cd994c5416816a2c0853becfa9f3f0ca2eebabc1889e76086b28277efeb23f9faf1d0aad023775902aa9fdd5c7525d6fec693a7834bac3c226ec SHA512 4417f56a68d7957713937d4d51e3156d2b446f6d758ecdfbb2806c153277479669012605803f488dc21b8f1ef9ef92565fcf1702bef4f0c08aa5d10b5af86851
EBUILD igraph-0.10.4.ebuild 1030 BLAKE2B 5b235af8c10ad6adfb0525db31253d93b6dddc49d2b8684128892b8ffa9ddec5fad7dcd17687c7940bacfe150fe92df78803030767dd3358fbc52e8da8e162af SHA512 00c22cc88e5b5024adee3caef0df9a9d42569eff965de6cb5a334408802b7f57daed4ab8b1e38055f35805fc64802c8620bd29d22f203584dc9510c147f57c5c
MISC metadata.xml 758 BLAKE2B 90df5f127db20d8d486a195a6c10d1e2159d2ca8ba1706adfec85c5317ef9b831ddf3595ab0f157cb30627db863fdeb72ce05d14bcd07291ec4735fd73a5e6b0 SHA512 3a5a7afe9387658aa41d587588af41b3cfae0c269e7da4badae23180b18c9854964942c292849321bc2c76feadcd4098223642f56736ca7a21a009d673446801
diff --git a/dev-libs/igraph/igraph-0.10.4-r1.ebuild b/dev-libs/igraph/igraph-0.10.4-r1.ebuild
new file mode 100644
index 000000000000..55e82ab3fb68
--- /dev/null
+++ b/dev-libs/igraph/igraph-0.10.4-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Creating and manipulating undirected and directed graphs"
+HOMEPAGE="https://igraph.org/"
+SRC_URI="https://github.com/igraph/igraph/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug test threads"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ dev-libs/libxml2
+ sci-libs/arpack
+ sci-mathematics/glpk:=
+ sci-mathematics/plfit
+ virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_CCACHE=OFF
+ -DIGRAPH_GLPK_SUPPORT=ON
+ -DIGRAPH_GRAPHML_SUPPORT=ON
+ -DIGRAPH_USE_INTERNAL_ARPACK=OFF
+ -DIGRAPH_USE_INTERNAL_BLAS=OFF
+ -DIGRAPH_USE_INTERNAL_GLPK=OFF
+ -DIGRAPH_USE_INTERNAL_GMP=OFF
+ -DIGRAPH_USE_INTERNAL_LAPACK=OFF
+ -DIGRAPH_USE_INTERNAL_PLFIT=OFF
+ -DIGRAPH_ENABLE_TLS=$(usex threads)
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_build check
+}