summaryrefslogtreecommitdiff
path: root/dev-libs/igraph/igraph-0.7.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/igraph/igraph-0.7.1-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/igraph/igraph-0.7.1-r2.ebuild')
-rw-r--r--dev-libs/igraph/igraph-0.7.1-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/igraph/igraph-0.7.1-r2.ebuild b/dev-libs/igraph/igraph-0.7.1-r2.ebuild
new file mode 100644
index 000000000000..83c2185d5b3e
--- /dev/null
+++ b/dev-libs/igraph/igraph-0.7.1-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Creating and manipulating undirected and directed graphs"
+HOMEPAGE="http://www.igraph.org/"
+SRC_URI="http://www.igraph.org/nightly/get/c/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug gmp"
+
+RDEPEND="
+ dev-libs/libxml2
+ >=sci-libs/arpack-3
+ virtual/blas
+ virtual/lapack
+ >=sci-libs/cxsparse-3
+ sci-mathematics/glpk
+ gmp? ( dev-libs/gmp:0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-unbundle.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ tc-export PKG_CONFIG
+ econf \
+ $(use_enable gmp) \
+ $(use_enable debug) \
+ --disable-tls \
+ --with-external-arpack \
+ --with-external-blas \
+ --with-external-lapack \
+ --with-external-f2c \
+ --with-external-glpk
+}