summaryrefslogtreecommitdiff
path: root/dev-libs/icu-le-hb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-libs/icu-le-hb
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-libs/icu-le-hb')
-rw-r--r--dev-libs/icu-le-hb/Manifest3
-rw-r--r--dev-libs/icu-le-hb/files/icu-le-hb-1.0.3-icu68.patch58
-rw-r--r--dev-libs/icu-le-hb/icu-le-hb-1.0.3-r1.ebuild4
3 files changed, 64 insertions, 1 deletions
diff --git a/dev-libs/icu-le-hb/Manifest b/dev-libs/icu-le-hb/Manifest
index 007658c05769..0239016c76cf 100644
--- a/dev-libs/icu-le-hb/Manifest
+++ b/dev-libs/icu-le-hb/Manifest
@@ -1,3 +1,4 @@
+AUX icu-le-hb-1.0.3-icu68.patch 1931 BLAKE2B 56bbb65821e575e2c270759f5ddd5107a2e4935295b0320dd6e69d902fb47bb851290d99704c609f82e9efaf35fd7dffe2c52ea0393bfe63abff20930883ea5d SHA512 1e2f8c079b9e1340d857bf09670958894c427eac20a29f564ef1d91b82b3eec7331b79dfc41ce172a95e2ab6678e41a42098e6af0da2af93ac5646415bbea010
DIST icu-le-hb-1.0.3.tar.gz 39352 BLAKE2B 7cc2e56b6ac334e0f9c259d4f9d0356480c1ae4eb647610ebfb81ee9b1bc0326f1dba68991e2893cc9b029ea53705cc0936cbbf29e74ab4ef336f58f5e8b47ab SHA512 06dff69bc17c39c13bd5bc801dbe09e2dc2f0cdf1acd774fa863e09f4a65820b2f330d4836da6748c077365f685fa74452ec1924785e3191cc2925036803cbb4
-EBUILD icu-le-hb-1.0.3-r1.ebuild 936 BLAKE2B 8c7d9f8567d1d40b8e1f48b900ef748ef748c5b9823d12bef22431d217ef175d0642607c9a39581b2f99c743f093f2f47b230c64187ab4ad63cb28aa0fc6dc2f SHA512 3350c4c4b441f56a0d797d810f1cc8c751a6dabc54f376bc4107f36496dd29118cc03915c3b943e22af1adef2beaa900f07976e44485cd0ea1db29fc2cc8bf66
+EBUILD icu-le-hb-1.0.3-r1.ebuild 989 BLAKE2B 3421aeb3459d7a8bd45b91936afc32f22f51dc2723b8ee67637675fdaca4d4b8bfb28bcca10574649c4b7bfe46dff91f47ae3b13997c92b26aec035f5b7208fd SHA512 bbb13e2d7ed73003a8c5f2f09f64a028ad56abce63ddd5df4b6b81302fb89c42c9b5e71294aff28471b279512014ee98576a5b019d869ae385f81ae212944dbf
MISC metadata.xml 464 BLAKE2B 326f9087cfc3c08145ed5ef2dd2c109fcf1c81ca3a8a4394504045361243c4e9db69fee1f47d67bb7aa9a91e3d6e62cc61f45a74b611d62c389a70e1a1829058 SHA512 40aeb13c0ee32afb9b58e3412bf26806bbf724deebd6b966477412df1889cfc62c90755820381d3622a535ce83ec7bf4e051f85dea84138b84bf553ecc7b84fb
diff --git a/dev-libs/icu-le-hb/files/icu-le-hb-1.0.3-icu68.patch b/dev-libs/icu-le-hb/files/icu-le-hb-1.0.3-icu68.patch
new file mode 100644
index 000000000000..9aa6958faff9
--- /dev/null
+++ b/dev-libs/icu-le-hb/files/icu-le-hb-1.0.3-icu68.patch
@@ -0,0 +1,58 @@
+From c0a0a85833cdcceb636dbe986f39a43ac40f839f Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Fri, 30 Oct 2020 15:04:44 +0100
+Subject: [PATCH] Fix build with icu-68.1
+
+icu-68.1 removed public macro definitions for TRUE and FALSE
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ src/LEFontInstance.cpp | 2 +-
+ src/LEGlyphStorage.cpp | 2 +-
+ src/LEInsertionList.cpp | 4 ++--
+ 3 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/LEFontInstance.cpp b/src/LEFontInstance.cpp
+index e5595f2..89bc3ed 100644
+--- a/src/LEFontInstance.cpp
++++ b/src/LEFontInstance.cpp
+@@ -79,7 +79,7 @@ void LEFontInstance::mapCharsToGlyphs(const LEUnicode chars[], le_int32 offset,
+
+ LEGlyphID LEFontInstance::mapCharToGlyph(LEUnicode32 ch, const LECharMapper *mapper) const
+ {
+- return mapCharToGlyph(ch, mapper, TRUE);
++ return mapCharToGlyph(ch, mapper, true);
+ }
+
+ LEGlyphID LEFontInstance::mapCharToGlyph(LEUnicode32 ch, const LECharMapper *mapper, le_bool filterZeroWidth) const
+diff --git a/src/LEGlyphStorage.cpp b/src/LEGlyphStorage.cpp
+index bac403a..b537676 100644
+--- a/src/LEGlyphStorage.cpp
++++ b/src/LEGlyphStorage.cpp
+@@ -659,7 +659,7 @@ le_bool LEGlyphStorage::applyInsertion(le_int32 atPosition, le_int32 count, LEGl
+ // just got replaced by the insertion
+ fSrcIndex -= 1;
+
+- return FALSE;
++ return false;
+ }
+
+ U_NAMESPACE_END
+diff --git a/src/LEInsertionList.cpp b/src/LEInsertionList.cpp
+index c64b8a1..3e39952 100644
+--- a/src/LEInsertionList.cpp
++++ b/src/LEInsertionList.cpp
+@@ -86,11 +86,11 @@ le_bool LEInsertionList::applyInsertions(LEInsertionCallback *callback)
+ {
+ for (InsertionRecord *rec = head; rec != NULL; rec = rec->next) {
+ if (callback->applyInsertion(rec->position, rec->count, rec->glyphs)) {
+- return TRUE;
++ return true;
+ }
+ }
+
+- return FALSE;
++ return false;
+ }
+
+ U_NAMESPACE_END
diff --git a/dev-libs/icu-le-hb/icu-le-hb-1.0.3-r1.ebuild b/dev-libs/icu-le-hb/icu-le-hb-1.0.3-r1.ebuild
index 29001e5eecca..fa6e7b24bd9a 100644
--- a/dev-libs/icu-le-hb/icu-le-hb-1.0.3-r1.ebuild
+++ b/dev-libs/icu-le-hb/icu-le-hb-1.0.3-r1.ebuild
@@ -27,6 +27,10 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}/${P}-icu68.patch" #751931
+)
+
src_prepare() {
default
eautoreconf