summaryrefslogtreecommitdiff
path: root/dev-libs/icu-le-hb/icu-le-hb-1.0.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-libs/icu-le-hb/icu-le-hb-1.0.3-r1.ebuild
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-libs/icu-le-hb/icu-le-hb-1.0.3-r1.ebuild')
-rw-r--r--dev-libs/icu-le-hb/icu-le-hb-1.0.3-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/icu-le-hb/icu-le-hb-1.0.3-r1.ebuild b/dev-libs/icu-le-hb/icu-le-hb-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..bc67bb2c0d34
--- /dev/null
+++ b/dev-libs/icu-le-hb/icu-le-hb-1.0.3-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="ICU Layout Engine API on top of HarfBuzz shaping library"
+HOMEPAGE="http://www.harfbuzz.org https://github.com/behdad/icu-le-hb"
+SRC_URI="https://github.com/behdad/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="icu"
+SLOT="0"
+
+KEYWORDS="~alpha amd64 hppa ~ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+# dev-libs/icu is not linked into icu-le-hb but the latter still needs
+# to be rebuilt on dev-libs/icu upgrades (see bug #621786).
+RDEPEND="
+ >=dev-libs/icu-58.1:=[${MULTILIB_USEDEP}]
+ media-libs/harfbuzz:=[${MULTILIB_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf --disable-static
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name "*.la" -delete || die
+}