summaryrefslogtreecommitdiff
path: root/dev-libs/icinga-php-library/icinga-php-library-0.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-17 11:36:49 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-17 11:36:49 +0100
commite2db47eaae00ec33f8971db44b68645c5d3b9590 (patch)
tree3ec0cf16ddb5854017e134fabebe14bf8cb94a34 /dev-libs/icinga-php-library/icinga-php-library-0.6.1.ebuild
parent616579b5d773c50af31ee56f00105d96ce641ca2 (diff)
gentoo resync : 17.08.2021
Diffstat (limited to 'dev-libs/icinga-php-library/icinga-php-library-0.6.1.ebuild')
-rw-r--r--dev-libs/icinga-php-library/icinga-php-library-0.6.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-libs/icinga-php-library/icinga-php-library-0.6.1.ebuild b/dev-libs/icinga-php-library/icinga-php-library-0.6.1.ebuild
new file mode 100644
index 000000000000..dd28d6824a35
--- /dev/null
+++ b/dev-libs/icinga-php-library/icinga-php-library-0.6.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Icinga PHP libraries for Icinga Web 2."
+HOMEPAGE="https://github.com/Icinga/icinga-php-library"
+MY_GITHUB_AUTHOR="Icinga"
+SRC_URI="https://github.com/${MY_GITHUB_AUTHOR}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="dev-lang/php:*"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_install() {
+ insinto "/usr/share/icinga-php/ipl"
+ doins -r "${S}"/vendor
+}