summaryrefslogtreecommitdiff
path: root/dev-libs/hyprland-protocols
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-26 00:12:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-26 00:12:24 +0100
commit9f6a82a85d400d6ae7de04c43cee88dbc6bc4da0 (patch)
tree2d53ee03e360a9c66a5d8dd8986eee286514336b /dev-libs/hyprland-protocols
parent996a2bda06cb164877d5d952774a6db1b271c2f3 (diff)
gentoo auto-resync : 26:06:2024 - 00:12:24
Diffstat (limited to 'dev-libs/hyprland-protocols')
-rw-r--r--dev-libs/hyprland-protocols/Manifest2
-rw-r--r--dev-libs/hyprland-protocols/hyprland-protocols-0.3.0.ebuild25
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/hyprland-protocols/Manifest b/dev-libs/hyprland-protocols/Manifest
index 4470ee7c7c08..458b7cdf4ed6 100644
--- a/dev-libs/hyprland-protocols/Manifest
+++ b/dev-libs/hyprland-protocols/Manifest
@@ -1,4 +1,6 @@
DIST hyprland-protocols-0.2.gh.tar.gz 6342 BLAKE2B a5179bc465156043903a5f17b1a4593ca15694ef22c52b1ba8a306d3680f1443a3c2ccf5947ace533244cc5b19ce02e8f3014053984f121f8e049882c1e21fa0 SHA512 cd1f9309a69236d6fd2ffc1a09f5f8a1196f357367779c08f30aeaaca7646be364c40fa8c207751012873085d24581fe7b7252c825e89958c20adfb48b029274
+DIST hyprland-protocols-0.3.0.gh.tar.gz 7423 BLAKE2B 1ecc6625152e9bd530490d8321dcbe41396dd7306066f6cd6d97c22a0ebb2c914348b6829e8d5e210f07807a7df282a1cc63fa44a93bd08df22987850bd27a3a SHA512 15bb0c45eed1949d888d228c671139fefd48e32d634823ed8041a4901e15e73409b0fd368d4c1f6197bd6980e723b20303697ad46b1171330cfd27821118ba32
EBUILD hyprland-protocols-0.2-r1.ebuild 536 BLAKE2B 2d1f7559cd73c432e0a7309f064125c8715b1276d5274c9946d47779385c4085cdcc6f4a9eb72e2e67f8940fe52ea1776c2a3f057994de2f4ed9480840493434 SHA512 d8d279d26715cabfebc962258d3d0a96d8c9f2186e21ec9f2b9fb8c144e1db7005bf990849cda396064df6ec887851088fbcaf31a0099bd558b7a86ab7d2ceec
+EBUILD hyprland-protocols-0.3.0.ebuild 537 BLAKE2B 9bb30ee0635a772203ac8ed670c029ebbd8918a40bf7c5698fcdccb49f070f6da51ecdd256d88c18ba30918162a97d62a9566dfa9037660ef3ff5676363936b3 SHA512 535c76604a1108348ab09c006489a318af44fca66ba8ad03c17a68631aa76146fda5f19b79f4e43164027cd41fc9bb87c44a24bb87f3132898ee3b2dec3b1421
EBUILD hyprland-protocols-9999.ebuild 536 BLAKE2B 2d1f7559cd73c432e0a7309f064125c8715b1276d5274c9946d47779385c4085cdcc6f4a9eb72e2e67f8940fe52ea1776c2a3f057994de2f4ed9480840493434 SHA512 d8d279d26715cabfebc962258d3d0a96d8c9f2186e21ec9f2b9fb8c144e1db7005bf990849cda396064df6ec887851088fbcaf31a0099bd558b7a86ab7d2ceec
MISC metadata.xml 478 BLAKE2B c6796b24b6747f8435dc6c2119bac1423a250d04127f4b6404b4ab194ce882da386d8e9b8778c49182f71dfb8ac61dc6530d43b5f66f59f4246eb8d954ac5d77 SHA512 d0b0f6fbea6829908600510cfe92ae8ef5106d60ff62e51955a9f15234412920273a05e6922ef09d469edcbe49788d35a7307dfeee57df657fbd9dedd724611d
diff --git a/dev-libs/hyprland-protocols/hyprland-protocols-0.3.0.ebuild b/dev-libs/hyprland-protocols/hyprland-protocols-0.3.0.ebuild
new file mode 100644
index 000000000000..f5179590cd2f
--- /dev/null
+++ b/dev-libs/hyprland-protocols/hyprland-protocols-0.3.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Wayland protocol extensions for Hyprland"
+HOMEPAGE="https://github.com/hyprwm/hyprland-protocols"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/hyprwm/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~riscv"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"