summaryrefslogtreecommitdiff
path: root/dev-libs/hyprland-protocols
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-03 19:55:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-03 19:55:55 +0000
commit0a3d5f62f59ea08933fd51b22c8c35ea85e2ce7c (patch)
tree3b5f42a35efeb767e8420d5a52a35234607a4248 /dev-libs/hyprland-protocols
parent94b475013eb88e152032d5f8c684a7d9ce91e319 (diff)
gentoo auto-resync : 03:01:2024 - 19:55:55
Diffstat (limited to 'dev-libs/hyprland-protocols')
-rw-r--r--dev-libs/hyprland-protocols/Manifest5
-rw-r--r--dev-libs/hyprland-protocols/hyprland-protocols-0.2-r1.ebuild (renamed from dev-libs/hyprland-protocols/hyprland-protocols-0.2.ebuild)16
-rw-r--r--dev-libs/hyprland-protocols/hyprland-protocols-9999.ebuild25
3 files changed, 37 insertions, 9 deletions
diff --git a/dev-libs/hyprland-protocols/Manifest b/dev-libs/hyprland-protocols/Manifest
index 4bbcdbdfbb5f..4470ee7c7c08 100644
--- a/dev-libs/hyprland-protocols/Manifest
+++ b/dev-libs/hyprland-protocols/Manifest
@@ -1,3 +1,4 @@
-DIST hyprland-protocols-0.2.tar.gz 6343 BLAKE2B cffa25c1fbac992db9aee57956615c2a5f8a6e90150d86246218e6d346e566a43527f56cab08b07359bd2f56b1e02b741fb0dbb37ec35fbadd22dfdb2006d3b0 SHA512 f8534c0f6562ce3c770ed9c79b8b78504d6f3aa75001c74ecfa5418af939e88a020ca1cef08d20c62e73c764d66452b5ce212a0f0d2e9a3aaba635ee80b142c5
-EBUILD hyprland-protocols-0.2.ebuild 532 BLAKE2B cd9861e2779f9e98c8fbdab5039fe307a815babc833c5497bc6cb6f9253fe7c29c912df9f393d9f4b03465e05eeb006a48fb4d828c0fbbaf271aa3e6dc2af010 SHA512 c203e4cbe291a407c76cbf6913565f792a741926a15470a54dd9c0d4564b40af046632e24906af6f97e8943e28825326f2a1094619ccdce0c8feb22bf94e24a6
+DIST hyprland-protocols-0.2.gh.tar.gz 6342 BLAKE2B a5179bc465156043903a5f17b1a4593ca15694ef22c52b1ba8a306d3680f1443a3c2ccf5947ace533244cc5b19ce02e8f3014053984f121f8e049882c1e21fa0 SHA512 cd1f9309a69236d6fd2ffc1a09f5f8a1196f357367779c08f30aeaaca7646be364c40fa8c207751012873085d24581fe7b7252c825e89958c20adfb48b029274
+EBUILD hyprland-protocols-0.2-r1.ebuild 536 BLAKE2B 2d1f7559cd73c432e0a7309f064125c8715b1276d5274c9946d47779385c4085cdcc6f4a9eb72e2e67f8940fe52ea1776c2a3f057994de2f4ed9480840493434 SHA512 d8d279d26715cabfebc962258d3d0a96d8c9f2186e21ec9f2b9fb8c144e1db7005bf990849cda396064df6ec887851088fbcaf31a0099bd558b7a86ab7d2ceec
+EBUILD hyprland-protocols-9999.ebuild 536 BLAKE2B 2d1f7559cd73c432e0a7309f064125c8715b1276d5274c9946d47779385c4085cdcc6f4a9eb72e2e67f8940fe52ea1776c2a3f057994de2f4ed9480840493434 SHA512 d8d279d26715cabfebc962258d3d0a96d8c9f2186e21ec9f2b9fb8c144e1db7005bf990849cda396064df6ec887851088fbcaf31a0099bd558b7a86ab7d2ceec
MISC metadata.xml 478 BLAKE2B c6796b24b6747f8435dc6c2119bac1423a250d04127f4b6404b4ab194ce882da386d8e9b8778c49182f71dfb8ac61dc6530d43b5f66f59f4246eb8d954ac5d77 SHA512 d0b0f6fbea6829908600510cfe92ae8ef5106d60ff62e51955a9f15234412920273a05e6922ef09d469edcbe49788d35a7307dfeee57df657fbd9dedd724611d
diff --git a/dev-libs/hyprland-protocols/hyprland-protocols-0.2.ebuild b/dev-libs/hyprland-protocols/hyprland-protocols-0.2-r1.ebuild
index bd84f17c8f6a..0de43fcf06fb 100644
--- a/dev-libs/hyprland-protocols/hyprland-protocols-0.2.ebuild
+++ b/dev-libs/hyprland-protocols/hyprland-protocols-0.2-r1.ebuild
@@ -1,22 +1,24 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit meson
-COMMIT=4d29e48433270a2af06b8bc711ca1fe5109746cd
DESCRIPTION="Wayland protocol extensions for Hyprland"
HOMEPAGE="https://github.com/hyprwm/hyprland-protocols"
-SRC_URI="https://github.com/hyprwm/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${COMMIT}"
-KEYWORDS="amd64 ~riscv"
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/hyprwm/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="amd64 ~riscv"
+fi
+
LICENSE="BSD"
SLOT="0"
-RDEPEND=""
-DEPEND="${RDEPEND}"
BDEPEND="
dev-util/wayland-scanner
virtual/pkgconfig
diff --git a/dev-libs/hyprland-protocols/hyprland-protocols-9999.ebuild b/dev-libs/hyprland-protocols/hyprland-protocols-9999.ebuild
new file mode 100644
index 000000000000..0de43fcf06fb
--- /dev/null
+++ b/dev-libs/hyprland-protocols/hyprland-protocols-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Wayland protocol extensions for Hyprland"
+HOMEPAGE="https://github.com/hyprwm/hyprland-protocols"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/hyprwm/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="amd64 ~riscv"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"