summaryrefslogtreecommitdiff
path: root/dev-libs/hyphen/hyphen-2.8.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/hyphen/hyphen-2.8.8.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/hyphen/hyphen-2.8.8.ebuild')
-rw-r--r--dev-libs/hyphen/hyphen-2.8.8.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/hyphen/hyphen-2.8.8.ebuild b/dev-libs/hyphen/hyphen-2.8.8.ebuild
new file mode 100644
index 000000000000..464620ed88d3
--- /dev/null
+++ b/dev-libs/hyphen/hyphen-2.8.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="ALTLinux hyphenation library"
+HOMEPAGE="http://hunspell.github.io/"
+SRC_URI="mirror://sourceforge/hunspell/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1 MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND="app-text/hunspell"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README{,_hyph_en_US.txt,.nonstandard,.hyphen,.compound} THANKS TODO )
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ docinto pdf
+ dodoc doc/*.pdf
+
+ rm -f "${ED}"usr/lib*/libhyphen.la
+}