summaryrefslogtreecommitdiff
path: root/dev-libs/http-fetcher/http-fetcher-1.1.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-13 07:41:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-13 07:41:53 +0100
commit4b91667ebe695e6fdfbef3962d099f17484b8806 (patch)
tree0af842488d683612bd9eae3f406ec839bcbc0cf9 /dev-libs/http-fetcher/http-fetcher-1.1.0-r2.ebuild
parentb89a664f266dab3b9b5ddac2cb874f8869142370 (diff)
gentoo auto-resync : 13:10:2022 - 07:41:53
Diffstat (limited to 'dev-libs/http-fetcher/http-fetcher-1.1.0-r2.ebuild')
-rw-r--r--dev-libs/http-fetcher/http-fetcher-1.1.0-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/http-fetcher/http-fetcher-1.1.0-r2.ebuild b/dev-libs/http-fetcher/http-fetcher-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..97ad5484327a
--- /dev/null
+++ b/dev-libs/http-fetcher/http-fetcher-1.1.0-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_P="${P/-/_}"
+
+DESCRIPTION="Library for downloading files via HTTP using the GET method"
+HOMEPAGE="http://http-fetcher.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc x86"
+IUSE="debug"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.0-underquoted-http-fetcher-macro.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-strict \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ dodoc -r docs/html/*.html docs/index.html README ChangeLog CREDITS INSTALL
+
+ find "${ED}" -name '*.la' -delete || die
+}