summaryrefslogtreecommitdiff
path: root/dev-libs/gtx/gtx-0.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/gtx/gtx-0.2.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/gtx/gtx-0.2.2.ebuild')
-rw-r--r--dev-libs/gtx/gtx-0.2.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/gtx/gtx-0.2.2.ebuild b/dev-libs/gtx/gtx-0.2.2.ebuild
new file mode 100644
index 000000000000..cee2d664b5c9
--- /dev/null
+++ b/dev-libs/gtx/gtx-0.2.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils
+
+DESCRIPTION="Small collection of functions intended to enhance the GLib testing framework"
+HOMEPAGE="https://launchpad.net/gtx"
+SRC_URI="https://launchpad.net/gtx/trunk/${PV}/+download/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE="debug doc static-libs"
+
+RDEPEND="dev-libs/glib:2"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-docdir.patch
+ "${FILESDIR}"/${P}-debug.patch
+ "${FILESDIR}"/${P}-glib.h.patch )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}