summaryrefslogtreecommitdiff
path: root/dev-libs/grantlee/grantlee-5.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-libs/grantlee/grantlee-5.1.0.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-libs/grantlee/grantlee-5.1.0.ebuild')
-rw-r--r--dev-libs/grantlee/grantlee-5.1.0.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/dev-libs/grantlee/grantlee-5.1.0.ebuild b/dev-libs/grantlee/grantlee-5.1.0.ebuild
deleted file mode 100644
index 8bcda9a613cb..000000000000
--- a/dev-libs/grantlee/grantlee-5.1.0.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-VIRTUALX_REQUIRED="test"
-inherit cmake-utils virtualx
-
-DESCRIPTION="C++ string template engine based on the Django template system"
-HOMEPAGE="https://github.com/steveire/grantlee"
-SRC_URI="http://downloads.grantlee.org/${P}.tar.gz"
-
-LICENSE="LGPL-2.1+"
-SLOT="5"
-KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 x86"
-IUSE="debug doc test"
-
-BDEPEND="
- doc? ( app-doc/doxygen[dot] )
-"
-RDEPEND="
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtscript:5
-"
-DEPEND="${RDEPEND}
- test? ( dev-qt/qttest:5 )
-"
-
-# bug 682258
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.3.0-nonfatal-warnings.patch"
- "${FILESDIR}/${P}-slot.patch"
- "${FILESDIR}/${P}-qt-5.13.patch"
- "${FILESDIR}/${P}-cxx11.patch"
-)
-
-src_prepare() {
- cmake-utils_src_prepare
- sed -e '/testfilters/d' \
- -i templates/tests/CMakeLists.txt || die # bug 661900
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_TESTS=$(usex test)
- )
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-
- use doc && cmake-utils_src_compile docs
-}
-
-src_test() {
- virtx cmake-utils_src_test
-}
-
-src_install() {
- use doc && HTML_DOCS=("${BUILD_DIR}/apidox/")
-
- cmake-utils_src_install
-}